keyboard and mouse no response when running Qt demo on OMAP EVM with Angstrom

Hi all,
I was developing GUI applications with Qt from Embedded Linux on OMAP
35x EVM(Mistral). I have a USB falsh drive, mouse and keyboard
connected to the board via a USB hub.

I booted the Linux kernel coming with TI evm sdk1.0.2 and Angstrom
dist I got from online image builder. I can mount the USB flash drive
and access its content.

I run a Qt demo program on the usb FLASH drive and the program was
able to display its main windows on the LCD touchscreen, but when I
click on the touchscreen it did not have any response.

I thought something wrong with the touch screen driver, so I switched
the display to DVI on my LCD monitor and
run the program again, hoping I can use external USB mouse connected
to the EVM board via a USB hub.
This time the program windows also shows up on my LCD monitor, but I
still can not way to move the mouse cursor.

I did some more tests, before I run my program, I was able to turn on/
off the "num Lock" light on the keyboard, while when the program is
runnig I can not do that. when the program is running I can not even
ctrl+c to stop it.
I typed on the keyboard randomly, sometime the program seems have
received some keystrokes, sometimes not.
it seems like the mouse and keyboard is recognized correctly by the
program after the program starts running.

BTW, I have tried this same demo program on Beagle board with Angstrom
demo image, it works perfectly. I can use mouse and keyboard to
interact witht the program. I just dont understand why it doesnt work
on omap EVM .

can anybody give me some insight on this issue?


does anybody know what could go wrong with my program?