KVM support on BBAI64

Hi,

Is it possible to enable kvm in the kernel?

I running the following version:

$ sudo beagle-version
[sudo] password for debian:
eeprom:[BBONEAI-64-B0-B0007801B00001643522BBBBBB2422]
model:[BeagleBoard.org_BeagleBone_AI-64]
dogtag:[BeagleBoard.org Debian Bullseye Minimal Image 2022-11-01]
bootloader:[/dev/mmcblk0boot0]:[tiboot3.bin]:[U-Boot SPL 2021.01-g8bafcf50 (Nov 10 2022 - 23:19:52 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/tiboot3.bin]:[U-Boot SPL 2021.01-g8bafcf50 (Nov 10 2022 - 23:19:52 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/tispl.bin]:[U-Boot SPL 2021.01-g8bafcf50 (Nov 10 2022 - 23:19:52 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/u-boot.img]:[U-Boot 2021.01-g8bafcf50 (Nov 10 2022 - 23:19:52 +0000)]
UBOOT: Booted Device-Tree:[k3-j721e-beagleboneai64.dts]
kernel:[5.10.145-ti-arm64-r72]

There is no trace of kvm in dmesg. Can it be enabled?

BR,
/j

Sorry, it’s currently disabled. I’ve been trying to get RT to work (which still doesn’t), but with v5.10.x-ti currently, it’s KVM or RT…

git clone -b ti-linux-arm64-5.10.y https://github.com/RobertCNelson/ti-linux-kernel-dev
cd ./ti-linux-kernel-dev
./build_deb.sh

When menuconfig pops up enable virtualization…

Once the linux-image.deb" finish building, just copy it over and install it with “sudo dpkg -i linux-image*.deb” and reboot…

Regards,

1 Like

My first attempt failed as I just enabled Virtualization in the top menu and missed that KVM was found in a sub-menu.

I could then successfully run firecracker on the bbai64 with good results:

root@ubuntu-fc-uvm:~# uname -a
Linux ubuntu-fc-uvm 4.14.174+ #14 SMP Mon Nov 23 20:44:24 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux
root@ubuntu-fc-uvm:~# systemd-analyze
Startup finished in 339ms (kernel) + 1.205s (userspace) = 1.544s
graphical.target reached after 1.109s in userspace

Did i miss any of your tested config’s?

i’m just going to spit ‘RT’ out in it’s own custom build…

Regards,

No, it looks exactly like my .config after enabling virtualization and KVM.