Last try with audio

PS Is this a stupid question ? Should I be able able to find out this on
a forum or an FAQ somewhere ? Or should I no there is no support by the
kernel version ? I asked a similar question last week but nobody
answered. If it is a silly question please note that I am new to linux
and I might not know this type of thing ?

First off, I am not the SW guy, but I did pose your quation and this is what O got back:

He might need something like

I haven’t checked if that’s in 2.6.33rc or alsa git yet.


Do you mean audio record or play? I am using 2.6.29 angstorm kernel.
There is no need to know .config
if you don't build kernel. I can play a wav file, but not record. In
addition, my audio works with mplayer, not with omapfbplay.

     I mean arecord doesn't work for me using 2.6.33-rc8. I should point
out that I am not using OE. I am just compiling the kernel with

I took the pre-built uImage + rootfs from the 2.6.29 Angstrom dist and
tried a little audio test program with that and it worked fine. I also
tried aplay and arecord in my /usr/bin and they worked as well.

I then tried the program with my build of 2.6.33 with my own guess
at .config settings using the menuconfig option during the make. I found
I could play pcm signals, but I couldn't capture any. The error looks
similar to one that was reported early 2009 but that was fixed. The
error is

I/O Error arecord: pcm_read:1347: read error: Input/output error.

Do you know where the _defconfig files are for the OE build ? I could
maybe compare those with my configuration.


'zcat /proc/config.gz' on a beagleboard itself. All angstrom kernels for beagleboard include the config in the uImage :slight_smile:

you might also want to peek at this: