Latest Debian Image(Specifics Below) Black Soundcard not recognized.

login as: root
Debian GNU/Linux 7 Debian Image 2015-11-03


default username:password is [debian:temppwd]

Last login: Wed Nov 18 21:36:53 2015 from
root@beaglebone:~# ls /proc/asound
cards devices oss pcm seq timers version
root@beaglebone:~# uname -a
Linux beaglebone 3.8.13-bone79 #1 SMP Tue Oct 13 20:44:55 UTC 2015 armv7l GNU/Linux

Hello All,

This is my first post so I apologize if I ask anything that should be obvious.

I built a custom audio cape based on the PCM5102A audio DAC from TI. With an older version of the image I could direct the sound output from mplayer or ffmpeg to the Black soundcard which is just straight I2S coming out of the pins and it worked beautifully. Now my project requires the use of a 4D systems 4DCape-70T so I updated to the latest Debian image. Now this image doesn’t have the Black soundcard, so I can’t get audio working.

I’ve tried doing an apt-get install of alsa-base and alsa-utils but it didn’t make a difference.

Any pointers would be greatly appreciated.

Best Regards,
Jorge Garcia

Well... By plugging the 4DCape-70T cape in, the hdmi & hdmi audio have
been disabled..

Since you were piggy back riding on the hdmi audio, you'll need to
enable audio....


Hi Robert,

Thanks so much for your help. I noticed you specified certain lines in the .dts file. Should I change my version of the file to match the lines you higlighted or do I need to make some other change?

I’m new to the BBB, so I thank you for your patience and help.

Best Regards,
Jorge Garcia

Hi Robert,

Here’s as far as I’ve gotten. From your response I figured you were hinting at me modifying the device tree overlay to enable the HDMI audio. I looked at the slots on my BBB and found that the screen is using the BB-BONE-LCD7-01-00A3 overlay. So I downloaded that one and modified it based on the example you provided.

Here is the result:


Hey hi Cad soft.
I have the exactly same issue as yours. I have built a custom audio DAC based on PCM5101A. So from so many discussions i found that on earlier versions of image till 3.8 it worked smoothly by loading the .dtbo file to /sys/devices/platform/bone_capemgr/slots and when we do cat slots,we can see our audio cape successfully loaded. But when i try on kernel versions 4.1.x or above, the device tree structure has changed and i guess now it works on uboot-overlay method. so i came across your post telling you also faced similar issue.I know its been a quite long time after you posted but i am totally stuck with this new overlay method and couldnt get solution. I am not an expert in linux . So can you please suggest if you got it working on new versions later? It will be really helpful . By the way just now i noticed i think i was following your github page only suggested by SHABAZ and trying to load jorge-audio-cape to the slots file. But ya it is not working on new images as i told already.waiting for your response.
thanks in advance.