LCD cape with 4.1 kernel

Has anyone gotten any LCD capes (4.3 or 7") to work with Ubuntu and the 4.1 kernel? Cape Manager seems to error out when loading firmware. Everything also seems to be mostly blank (no pins used, no pinmux values, etc.).

dtc --version

uname -r

dmesg | grep bone


ubuntu@arm:~$ dtc --version
Version: DTC 1.4.1-g2a37d2d8
ubuntu@arm:~$ uname -r
ubuntu@arm:~$ dmesg|grep bone
[ 0.000000] Linux version 4.1.0-rc8-bone9 (root@a4-imx6q-wandboard-2gb) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-19ubuntu1) ) #1 Wed Jun 17 02:36:41 UTC 2015
[ 3.111917] usb usb1: Manufacturer: Linux 4.1.0-rc8-bone9 musb-hcd
[ 3.270249] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,00C0,3214BBBK6007’
[ 3.270270] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 3.322347] bone_capemgr bone_capemgr: slot #0: No cape found
[ 3.382332] bone_capemgr bone_capemgr: slot #1: No cape found
[ 3.442331] bone_capemgr bone_capemgr: slot #2: No cape found
[ 3.472330] bone_capemgr bone_capemgr: slot #3: ‘4D 4.3 LCD CAPE- 4DCAPE-43T ,00A1,4D SYSTEMS ,BB-BONE-LCD4-01’
[ 3.472514] bone_capemgr bone_capemgr: initialized OK.
[ 4.482478] bone_capemgr bone_capemgr: loader: failed to load slot-3 BB-BONE-LCD4-01:00A1 (prio 0)

Thanks Philip,

Pretty much replicated on ubuntu trusty...

I'm going to quickly verify debian jessie isn't broken. But ubuntu
might be doing something funny with the location of *.dtbo, i've been
shoving them under /lib/firmware (and copying them to the


Fun... regressions across the board.. looks like a dtc version issue..


Okay, back to testing trusty... on debian since i don't have the cape
plugged, i have to override, and i forgot the ":00A1" part..


Nope, works perfect:

ubuntu@arm:~$ dmesg | grep bone
[ 0.000000] Linux version 4.1.1-bone9 (root@a5-imx6q-wandboard-2gb)
(gcc version 4.8.4 (Ubuntu/Linaro 4.8.4-2ubuntu1~14.04) ) #1 Tue Jun
30 17:32:28 UTC 2015
[ 0.000000] Kernel command line: console=tty0
console=ttyO0,115200n8 bone_capemgr.enable_partno=BB-BONE-LCD4-01:00A1
root=/dev/mmcblk0p1 rootfstype=ext4 rootwait fixrtc coherent_pool=1M
[ 3.036329] usb usb1: Manufacturer: Linux 4.1.1-bone9 musb-hcd
[ 3.166983] bone_capemgr bone_capemgr: Baseboard:
[ 3.167006] bone_capemgr bone_capemgr:
compatible-baseboard=ti,beaglebone-black - #slots=4
[ 3.222207] bone_capemgr bone_capemgr: slot #0: No cape found
[ 3.282234] bone_capemgr bone_capemgr: slot #1: No cape found
[ 3.342193] bone_capemgr bone_capemgr: slot #2: No cape found
[ 3.402194] bone_capemgr bone_capemgr: slot #3: No cape found
[ 3.408242] bone_capemgr bone_capemgr: enabled_partno PARTNO
'BB-BONE-LCD4-01' VER '00A1' PR '0'
[ 3.408252] bone_capemgr bone_capemgr: slot #4: override
[ 3.408264] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 3.408278] bone_capemgr bone_capemgr: slot #4: 'Override Board
Name,00A1,Override Manuf,BB-BONE-LCD4-01'
[ 3.408506] bone_capemgr bone_capemgr: initialized OK.
[ 4.436414] bone_capemgr bone_capemgr: slot #4: dtbo
'BB-BONE-LCD4-01-00A1.dtbo' loaded; overlay id #0
ubuntu@arm:~$ cat /boot/uEnv.txt | grep dtb

I'm going to guess, you didn't set dtb=

Like shown under "BBB compatibility issues:"

Use blank overlay (HDMI & eMMC disabled) (/boot/uEnv.txt):

Disable: HDMI


Had to re-install the kernel and now it is recognized as it should be. Many thanks! Now on to the next challenge… fixing the windowing system yet again.

Now on to the next challenge… fixing the windowing system yet again.

Lubuntu ! That’s my cure anyhow . . .


It is for my not clear how the uEnv.txt should look like!

I have the 4DCAPE-43T

can you show my how the uEnv.txt file should look like? I am only using that LCD cape.
The software is: BBB eMMC flasher-debian-8.1-console armhf-2015-07-08-2gb
I have followed teh instructions on this page:



Good afternoon

would you be so kind to advise, if there is any mistake in my numerous attempts to connect 4dcape-43t to BBB. I’ve been trying on a number of images, following various instructions from internet, but the screen is still black.

ubuntu@arm:~$ uname -a
Linux arm 4.1.15-ti-rt-r40 #1 SMP PREEMPT RT Fri Jan 8 09:44:57 UTC 2016 armv7l armv7l armv7l GNU/Linux
ubuntu@arm:~$ dtc --version
Version: DTC 1.4.1-g1e75ebc9

I have followed instructions from , still getting :

ubuntu@arm:~$ dmesg | grep bone
[ 3.966185] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,00C0,2315BBBK3AC2’
[ 3.966228] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 4.022102] bone_capemgr bone_capemgr: slot #0: No cape found
[ 4.082075] bone_capemgr bone_capemgr: slot #1: No cape found
[ 4.142069] bone_capemgr bone_capemgr: slot #2: No cape found
[ 4.202069] bone_capemgr bone_capemgr: slot #3: No cape found
[ 4.208038] bone_capemgr bone_capemgr: initialized OK.

Please advise

hi dear robert
i am farahani
we designed new pcb with base “begaleboneblack” siatara am3358
i run kernel version 3.8.x bone 80
bone 80 need for rtl8732 wifi
i run lcd 4.3" for 4dsystem company and run .dtbo " BB-BONE-LCD4-01-00A1" when use cat /sys/devices/bone_capemgr*/slots
run config file or dtbo in eeprom when startup.
and run , no problom,
in the my pcb place aic codec and run with echo BB-BONE-AUDI-02 > /sys/devices/bone_capemgr*/slots
run cound card and no problem.
when i use both.mean lcd with audio renamue BB-BONE-AUDI-02-00A0.DTS TO BB-BONE-AUDI-03-00A0.DTS

dtc -O dtb -o BB-BONE-AUDI-03-00A0.dtbo -b 0 -@ BB-BONE-AUDI-03-00A0.dts
mv BB-BONE-AUDI-02-00A0.dtbo /lib/firmware