LCD4 Backlight brightness

james,

for the current 3.8 development release the pwm control of the backlight has not been enabled. it is simple either off (0%) or on (100%). future version will including this functionality…

Dave

James,

which image release were you using?

i didn’t think we had the pwm enabled yet… were you able to set it to 50%?

Dave

Please share how you got this working? I haven’t been able to get anything on the screen yet at all so far :frowning:

Ehm, it has had backlight control ever since LCD4 support was added. I have an LCD4 plugged into a BBB and it shows a /sys/class/backlight/ and has a slider in the GUI.

Koen how do I get something displayed on the LCD4 with the builds? I built what was the latest on Friday which should have the changes but I get nothing on the screen. I was expecting to see the console output but nothing. The Backlight is on though.

Pete

Koen,

where is the slider in the GUI?
I find the GUI s crammed onto the little screen and most menus etc fail to display correctly and dont fit the screen. Most screens can not be scrolled either in order to see all their content...

Settings -> power management

I think I may need to try and update my kernel. I rebuilt from scratch on the 24th but I get this on the console at boot.

Booting kernel from Legacy Image at 80007fc0 …

Image Name: Angstrom/3.8.13/beaglebone
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 4225760 Bytes = 4 MiB
Load Address: 80008000
Entry Point: 80008000
Verifying Checksum … OK

Flattened Device Tree blob at 80f80000

Booting using the fdt blob at 0x80f80000
XIP Kernel Image … OK
OK
Using Device Tree in place at 80f80000, end 80f88cd8

Starting kernel …

Uncompressing Linux… done, booting the kernel.
[ 0.191977] omap2_mbox_probe: platform not supported
[ 0.202437] tps65217-bl tps65217-bl: no platform data provided
[ 0.302759] bone-capemgr bone_capemgr.9: slot #1: No cape found
[ 0.339867] bone-capemgr bone_capemgr.9: slot #2: No cape found
[ 0.376977] bone-capemgr bone_capemgr.9: slot #3: No cape found
[ 0.419040] omap_hsmmc mmc.4: of_parse_phandle_with_args of ‘reset’ failed
[ 0.483044] pinctrl-single 44e10800.pinmux: pin 44e10854 already requested by 44e10800.pinmux; cannot claim for gpio-leds.8
[ 0.494773] pinctrl-single 44e10800.pinmux: pin-21 (gpio-leds.8) status -22
[ 0.502075] pinctrl-single 44e10800.pinmux: could not request pin 21 on device pinctrl-single
[ 0.529983] pinctrl-single 44e10800.pinmux: pin 44e108a0 already requested by hdmi.16; cannot claim for panel.14
[ 0.540703] pinctrl-single 44e10800.pinmux: pin-40 (panel.14) status -22
[ 0.547737] pinctrl-single 44e10800.pinmux: could not request pin 40 on device pinctrl-single
[ 0.556668] panel panel.14: Failed to select default state
[ 6.215514] libphy: PHY 4a101000.mdio:01 not found
[ 6.220570] net eth0: phy 4a101000.mdio:01 not found on slave 1
systemd-fsck[83]: Angstrom: clean, 46685/112672 files, 270683/449820 blocks

.—O---.

.-. o o

-----.-----.-----.| | .----…-----.-----.
__ | —’| ‘–.| .-’| | |

— || --’| | | ’ | | | |
‘—’---’–’--’–. |-----’’----’’–’ ‘-----’-’-’-’
-’ |
‘—’

The Angstrom Distribution beaglebone ttyO0

Angstrom v2012.12 - Kernel 3.8.13

So it looks like an issue with HDMI on my BBB?

Hold down the ALT key then if using touch screen touch somewhere (anywhere) on the window and drag it up. If using a mouse then left click somewhere on the window and drag it up.

James,

please register over at http://bugs.elinux.org and file a bug report so we can track this…

Dave

James,

Very strange, just to make sure I hadn’t made any changes to make it work I have just re-flashed the latest 2013-05-27 Angstrom and tried it again. Works no problem for me, however, I did notice if I try ALT and dragging the window by it’s top bar then that does stop below the main menu bar at the top of the screen. Selecting any point lower down works.

As I understand it this is standard functionality, it works the same way on my Ubuntu desktop on my PC.

Brian

I just installed latest (Angstrom 3.8.13 June 18) from http://beagleboard.org/latest-images/ and have ‘backlight.10’ in /sys/class/backlight. I can echo values to /sys/class/backlight/backlight.10/brightness successfully - but the GUI slider has no effect. I can slide it, but nothing happens.
How can I troubleshoot this issue? I’m not sure where to find error messages - nothing shows up in dmesg. Do I need a serial cable for this? Why does everyone else have backlight.11 when I have backlight.10?
I tried to make a symlink called backlight.11 but it wouldn’t let me - even if I tried putting it in /devices/…/…

My hardware is BBB Rev A5C with LCD screen 4DCAPE-43T Rev 1.11

Thanks Koen!

Hi
Yes I have the same thing, the slider does not seem to do anything. Changing the PWM value with the echo does however.
Yes I have backlight.10 also, maybe with older releases it was .11, I am not sure.

For interests sake, where would I find the place where the PWM for the backlight is controlled from?
I would like to find out how to change the PWM frequency. I believe it is currently set at 2Khz.
Is this possible to change to 1Khz for example?
If so, could someone point me to where I need to look?

I have run Android 4.2.2 successfully and checked the PWM frequency on that too, and that is also 2Khz.

Regards
Terry

I have been doing some reading.

In the DTS file for the BB-BONE-LCD4-01-00A1.dts, there is the PWM settings which is currently set to 500000 which is in nanoseconds, which is 2Khz. Which is good.
Changing this value to 1000000 which is 1Khz, and then running this command:

dtc -O dtb -o BB-BONE-LCD4-01-00A1.dtbo -b 0 -@ BB-BONE-LCD4-01-00A1.dts
to compile it
I then restarted, and the frequency was still 2Khz.

Can anyone suggest what I am not doing or something else I need to do?

Thanks
Terry