My experience.

I’ve purchased:

  • a power supply
  • a nano wireless dongle
  • a micro HDMI - HDMI cable
  • an HDMI - male DVI adapter
  • a powered USB hub (four ports - switchable (on/off)
  • usb keyboard
  • wireless mouse

It came with micro USB - USB cable.

Trial and error got the main page (CONNECTED) working.

Interesting to find that (from Youtube) plugging in the nano dongle
turns the beagleboard ON.

Wasn’t working under Bodhi Linux. Could’'ve been the OS.
Could’ve also been the components connected to the Beagleboard.
Reduced the components to the bare minimum and removed the
complications of an existing OS by booting Live CD and trying it
that way. If it worked at all, seemed to suggest that less is better
at least in troubleshooting.

Haven’t been able to get the wireless dongle to work.

Frustrating in that it seems to (at least everything I’ve looked at)
be predicated upon ONE specific connection. Doesn’t seem to
(like Windows) be able to see a list of available connections from which
to choose. (Again, maybe I’m missing something.)

The Powered USB doesn’t work. Might be what I’ve got.

If I use a regular unpowered USB hub that works, but, in terms of
trying to setup external storage via an external drive, figure also:

keyboard, mouse, wireless dongle

and that doesn’t quite look like a viable alternative.

Also, as mentioned in a previous post, I haven’t been able to get
a Debian install to boot from Micro SD. Built in Angstrom works just
fine. Boots to login prompts but startx reports back “command not
found”. Again, maybe I’m doing something wrong.

So, so far, based on the advert, I haven’t been able to use the
beagleboard black to it’s full potential.

I’d like to use it as an educational tool. Understandably, before I
ask students to to it, I’d like to be able to do it myself. These are
just the basics nevermind the advanced stuff. But, if I can get past
the basics, I can begin tinkering with the more advanced possibilities
like the portable cape (battery operated), the weather cape, which isn’t
fully compatible yet, and the (looks super simple) temperature sensor

By comparison, I’ve played with the Raspberry Pi:

Changed OS.
Installed XBMC.
Configured for Headless connection.
Connected to HDMI as well as DVI monitor (with adapter).
Played around a little with Scratch - a LOT with Python.

And I HAVE logged in via SSH to the beagleboard and used the
Gateway for JS scripting, but, what I’ve saved and run hasn’t worked.
(And that’s no more than copying the script off the main page and then
saving it.)

Did a basic “hello world” test in Python. That worked.

Tried doing the same in JS (javascript). That didn’t.

The blinking LEDs worked.
(Wondering. Is there a morse code script for the LEDs? I’ve
seen an Arduino script for that - could it be adapted for the beagleboard
black? - Something that either allows for command line translation or
text file translation.)

Just one person’s views, experiences, ideas.

Got anything to add, clarify, suggest?

Feel free.


Then to install "xorg/lxde" via:

cd /boot/uboot/tools/debian/

20mins later (using your internet connection), reboot, lxde desktop..



Then to install “xorg/lxde” via:

cd /boot/uboot/tools/debian/
./small-lxde-desktop.sh "

Contents of



No tools subdir.

This is what I downloaded from:



File size was 89.9 mb

And yet according to you "I haven't been able to get a Debian install
to boot from Micro SD"...

So option
1: use armhf.com's image, which hasn't been updated since "June 9, 2013"

2: use my image:

For which i've been supporting Debian on the Beagle family for i don't
know, four to five years?


Gosh, Robert.

On that page, it states:

“The kernel is a Robert Nelson armhf 3.8 kernel.”

I’m guessing the very same “Robert Nelson” as stated below.

“June 9, 2013”

that would be, what, about a month ago?

Downloaded from the other page as well, after all, what the hell do I know?

You’re right. Might make a difference.

It didn’t.

As I mentioned in a previous post, go ahead, treat me like I’m an idiot.

Guess you have.


Well obviously this discussion is currently going no where...

Based on your email, I thought you wanted help, as I gave you a link
to an "image" that'll boot out of the box.


Mike, honestly Robert has been more than kind, and has treated you with more respect than I may have. The problem you having is no ones fault but your own. See this thing where you need help, typically you ask nicely. Instead of acting as though the problem lies elsewhere. But rest assured, the problem is all your own fault.

At what point in this conversation did I EVER suggest otherwise?

I’m OBVIOUSLY doing something wrong.

I looked back at the main “Getting Started” page to see if there was a link to the Debian image.

There’s not.

I stumbled upon the ArmHF page. I could’ve just as easily stumbled upon Robert’s page. I didn’t.

There seemed to be a degree of assumption about what I’d done, hadn’t done, or should’ve known
in Robert’s next to last response. It came across as condescending.

If that’s what’s then construed as “kind”, I guess I missed that definition.

Now, I’m just another know nothing troublemaker.

I not once questioned that Robert’s image works. You, William, are right, it’s MY fault. I wind up having
to say that a LOT for some reason it gets lost in the discussion. I never said, REALLY - me argue with
an Applications Engineer over HIS code, that I was right and he was wrong on THAT count.

I responded to his attitude as I interpreted it.

Guess I won’t be getting any more “help” from him.

This all started with what I reported that I’d downloaded. I never said it was better or preferred over
ANYTHING Robert had to offer. And I further clarified that.

Robert appeared to take it personally.

Why would I do that other than what he proposed?

Dumb luck.

When you DON’T know, it’s just as easy to make a bad decision as a good one.

Robert seemed to think it was a deliberate, thoughtful choice.

It wasn’t. It was Google. No more no less.

Next time, I’ll try to make a less offensive absolutely random choice.

Great, now I see that you, WIlliam, are a Software Engineer.

Between you and Robert, what I do not know is profound in comparison.

It was just my intention to state my experience. I did say “I must be doing something

How did that get missed?

I’m new to the beagleboard, new to the raspberry pi.

Aw nuts.

I’m smart enough, I’ll figure something out.

I’m not saying, not implying, nor did I ever intend to suggest that it’s anything other than

ME and what I don’t know.

That and a dime isn’t getting me anywhere.

In the back of my mind is the understanding that so many others have figured this out,
gotten it working - software engineers, application engineers. And average joes, janes.

It’s solvable. I just haven’t solved it yet.

I will.

These are just problems I haven’t solved yet.

Moving on.

Mike, so let us try to be nice.

First let me say that I am not that experienced with embedded Linux, but I do have years of Debian experiences. Limited as that may be.

It took me 3-4 tries to follow Robert’s instructions, and get it right. Why ? Because I was very rusty with Linux ( had not touched Debian/Linux much in the last few years ). That, and judging by Roberts instructions, he seems to assume we know some basics where Linux command line is concerned. So without trying to dig too deep into what someone else is thinking, I would suggest you follow Robert’s build from source instructions, or pick up one of his prebuilt images, and follow those instructions. Why ? Because Robert is very active, and has lots of information out there for his support scripts, and instructions. Also, I know it works, and it works well. I can not overstate this last part enough. Not to mention, when you ask a question concerning his build instructions, he tends to answer. Just do not expect anyone here to be too patient with answering basic Linux knowledge type stuff Google is key here…

I might recommend using the build from source instructions, as it shows you how to properly ( at least in my own mind ) setup an ARM cross compiler that will work for much more than just compiling the kernel / u-boot. Just keep in mind that these instructions are not easy to grok at first, and require some thinking on your own behalf.

http://eewiki.net/display/linuxonarm/BeagleBone+Black to build uboot, and the kernel from source. These instructions will also most likely take you the better part of a day to complete( read: roughly 10-12 hours if you have a 1.5Mbit internet connection ). I am also working on a blog post that covers USB hard drive booting ( beaglebone black ) that walks through Roberts whole set of instructions up until setting up the SD card ( where I diverge ). This is only important, because I will be spending the time assuming the user following the instructions knows very little about Linux passed the Debian install process ( on the cross compile support system, or PC ).

The prebuilt image instructions I believe are linked from Circuitco’s pages.

Or, you can go with armhf.com’s build, and hope for support ( I really have no idea how good the community is there ). Plus here . . . people actually know the hardware. No matter which distro they prefer, much of it is the same.


Thank you.

I will take a look at what you, Robert, and everyone I can find of some credibility
on the subject has to say.

Like I said, I’ll work it through. Probably take me a while to figure it out, but, I’m
persistent. I haven’t figured out everything Linux related, but, I’ve got it up and
running on three laptops, several USB flash drives and am evolving into the raspberry

pi, beaglebone, and arduino territory (largely, for me uncharted).

I try not be a PITA, (Pain in the … for the curious). I also try to be honest.





I’ve installed:





using the instructions found here:


and here (Android):


I’ve been able to boot all to a prompt and login (Ubuntu / Debian)
using the instructions from ArmHF.

I tried installing ubuntu-desktop:

opkg install ubuntu-desktop

8 GB micro card - ran out of room.

Android booted to GUI / OS, but, after that, I didn’t quite know what to do with it.
I don’t have an Android phone, so, not really sure what to expect. Curious about
Android app development, that’s why I tried it in the first place. Not sure it’s not
working as intended or for that matter if loading it on the Beaglebone Black is essential
for Android development.

Had some initial problems booting up. Might’ve been that I was using a DVI connector
to a PC monitor with a DVI connector. Tried it at home with the micro HDMI to an HD
TV. That seemed to work ok. Could be that it’s just not configured for DVI (or that it
needed proper configuration (proper editing of some script). It worked on HDMI, but, not
on DVI.

Given that it’s just easier all around booting to Angstrom, not sure of the benefits to
be had from booting to a Debian, Ubuntu command line.

Or, if booting to a GUI is preferable, if it’s worth the time and headache figuring out how
to get there from the command line.

Either way, I got them to work as instructed.