Leopard VGA Camera "Product ID error"

Hey Guys,

I am trying to use the BBxM with the Leopard VGA camera but getting
When I have the camera connected and boot the Angstrom verification
Image that came with the BB, the camera board seems to be recognized
during boot: "Beagle cameraboard: lbcm3m1"

However, later on in the boot, I get an error message: "mt9t112
2-003c: Product ID error 2280" and Once I log-in, no camera device is
listed at /dev/video0

Using the new Angstrom BB demo Image, I can't get OpenCV to find the
camera. And when booting this Image, I get a Fatal Error (not sure if
its related to camera problems):

[ 469.490112] CMEM Range Overlaps Kernel Physical - allowing overlap
[ 469.497680] CMEM phys_start (0x86300000) overlaps kernel
(0x80000000 -> 0xa0000000)
[ 469.515411] CMEMK Error: Failed to request_mem_region(0x86300000,
FATAL: Error inserting cmemk (/lib/modules/2.6.32/kernel/drivers/dsp/
cmemk.ko): Bad address

Any help/advice is greatly appreciated,


From the information you mentioned below it seems you have VGA camera (ID = 0x2280) while you have configured the system for 3MP camera (lbcm3m1).

Change the camera type in boot.scr from "lbcm3m1" to "lbcmvga". I hope this is the only problem you have.

Good luck!


Thanks for your help.

I tried using boot.scr but got a kernel panic. So, I stopped autoboot
and set the camera at the cmdline: "setenv camera lbcmvga"

This changed the camera type, but still no /dev/video0 when using the
verification image or Angstrom demo Image

Also tried the camera on the demo image with OpenCV and TI texture
demo but still cannot find camera. Even with setenv camera lbcmvga at

Do you have any debugging recommendations?



See below.



I am not familiar with the "editboorscr" command you mentioned and I
do not have an original boot.scr file.

So, I created a boot.scr using the following procedure from another

a) Make a file (my_boot_cmd) with your new U-Boot commands:
    mmc init
    setenv camera lbcmvga
    run loaduimage
    run mmcboot

b) Use mkimage command (on ubuntu "apt-get install uboot-mkimage"):
    mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n
"Beagleboard-xM boot script" -d my_boot_cmd boot.scr

c) Copy boot.scr to the FAT partition on your SD card (where you have
MLO, u-boot.bin, uImage etc.).

I used this boot.scr with the newest Angstrom demo image. The boot
output says "Beagle cameraboard: lbcmvga". However, no video0 device
shows up, and the TI streaming demo and OpenCV cannot find the camera.

Do you think the Fatal error with cmemk has anything to do with my

I appreciate your help,

Even I am trying to connect my Leopard 2M camera module to the BB xm
running Angstrom (image build following the steps given on BB Google
code page)

I am not able to see the the device in /dev/ folder and during boot it
"Beagle cameraboard: lbcm3m1" as the connected device. I tried the
editbootscr command, but it looks like there is no such command
installed on my system (Ubuntu 10.10), let me know how to get
editbootscr command.

Here is the complete boot log, http://pastebin.com/d88JckpV
Please advice how to get the camera running so that it can be used
using OpenCV.

Thanks much


I am still not having luck with my VGA camera and my BBxM. However, here is some info regarding boot.scr scripts:

  1. You can get sample boot.scr scripts by executing this on your BB running Angstrom: opkg install angstrom-uboot-scripts

  2. You can take one of these sample scripts and add in a line for the camera. In my case, I am using the VGA so I added: setenv camera lbcmvga

  3. Then you need to create an executable file using mkimage. To get this, use: opkg install u-boot-mkimage (add possibly u-boot-mkimage-dev as well). Then run: mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n ‘Execute uImage.bin’ -d name_of_boot_text_file boot.scr

  4. Move boot.scr to your 1st SD card partition, reboot, and your new boot.scr will be run.



I have attached the boot.scr (I renamed it to boot.bin as outlook doesn't allow me to send .scr files, rename it to boot.scr) file I used to make the VGA camera working. Give it a try and send the debug messages.


boot.bin (773 Bytes)


Thanks for your help. I have tried your boot.scr and have some errors. First, here is the boot output which might be an issue with the “setenv” command:

mmc1 is available
The user button is currently NOT pressed.
reading boot.scr

773 bytes read
Running bootscript from mmc …

Executing script at 80200000

mmc1 is available
reading uImage

3195484 bytes read
Booting from mmc …
setenv - set environment variables

setenv name value …

  • set environment variable ‘name’ to ‘value …’
    setenv name
  • delete environment variable ‘name’

Booting kernel from Legacy Image at 80200000 …

Image Name: Angstrom/2.6.32/beagleboard

Next, I am getting a kernel panic:

Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy
VFS: Cannot open root device “(null)” or unknown-block(2,0)
Please append a correct “root=” boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)