LIRC and BeagleBone Black

Hello all. This is my first post here after digging a lot about LIRC.

I just got my BBB and I’m using the original SO version.

uname -a

Linux beaglebone 3.8.13-bone47 #1 SMP Fri Apr 11 01:36:09 UTC 2014 armv7l GNU/Linux

lsb_release -a

No LSB modules are available.

Distributor ID: Debian

Description: Debian GNU/Linux 7.4 (wheezy)

Release: 7.4

Codename: wheezy

What I need it to send IR commands to a IR led on pin9_14.

My questions:

  1. is it necessary to recompile the kernel to have LIRC working or it’s enough to apt-get install lirc?

  2. once LIRC is installed how and where I tell LIRC to send it pin0_14?

  3. Do I have to enable UART4 for doing so?

Resuming, I saw some node modules for working with LIRC, but could not make LIRC to work.
My need is simply be able to send commands (power on/off, vol up/down, etc) to my Samsung TV.

Best regards and thanks in advance.

Firstly, yes, you have to recompile your kernel on BBB to get LIRC working. Here’s a nice howto to get your IR sending to work on BBB:


Thanks, Rene.

I did it and succesfully rebooted BBB.

However, when I tried to modprob, I got:

root@beaglebone:~# modprobe lirc_bbb
libkmod: ERROR …/libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file ‘/lib/modules/3.8.13-bone50-GL/modules.dep.bin’

Bellow you see the contents of '/lib/modules/3.8.13-bone50-GL/

root@beaglebone:/lib/modules/3.8.13-bone50# ls -la
total 1252
drwxr-xr-x 3 root root 4096 Feb 13 01:05 .
drwxr-xr-x 3 root root 4096 Feb 12 18:25 …
lrwxrwxrwx 1 root root 28 Feb 13 01:05 build → /usr/src/linux-3.8.13-bone50
drwxr-xr-x 9 root root 4096 May 13 2014 kernel
-rw-r–r-- 1 root root 327125 May 15 2014 modules.alias
-rw-r–r-- 1 root root 347363 May 15 2014 modules.alias.bin
-rw-r–r-- 1 root root 14230 May 13 2014 modules.builtin
-rw-r–r-- 1 root root 16918 May 15 2014 modules.builtin.bin
-rw-r–r-- 1 root root 89181 May 15 2014 modules.dep
-rw-r–r-- 1 root root 143882 May 15 2014 modules.dep.bin
-rw-r–r-- 1 root root 140 May 15 2014 modules.devname
-rw-r–r-- 1 root root 50010 May 13 2014 modules.order
-rw-r–r-- 1 root root 131 May 15 2014 modules.softdep
-rw-r–r-- 1 root root 111721 May 15 2014 modules.symbols
-rw-r–r-- 1 root root 142850 May 15 2014 modules.symbols.bin

Any idea?

Best regards,


Well, I tried

ln -s /lib/modules/3.8.13-bone50 /lib/modules/3.8.13-bone50-GL

and got a new error:

root@beaglebone:/lib/modules/3.8.13-bone50-GL# modprobe lirc_bbb FATAL: Module lirc_bbb not found.

Just to make

root@beaglebone:/lib/modules/3.8.13-bone50-GL# uname -a Linux beaglebone 3.8.13-bone50-GL #1 SMP Fri Feb 13 13:11:23 UTC 2015 armv7l GNU/Linux