Load capes by default on AM335x without EEPROM ?


I’m currently working on a custom BeagleBone Black of ours and I have a few problem. The electronic is the same except that there is no graphic chip and no EEPROM.

I’m booting on a µSD card the Angstrom distribution used in the BBB. The board is working well except that I have the following message during the boot “[ 5.561536] bone-capemgr bone_capemgr.9: Failed to scan baseboard eeprom”.

This is perfectly normal because I have no EEPROM. My problem is that I didn’t know that the EEPROM was mandatory to initialize the cape manager. Thus, my EMMC is not loaded by the OS.

I already tried to enable the cape with the uEnv.txt but it did nothing.
I also tried to load it manually but in my cape manager folder there is no “slot” file so i guess that the cape manager is simply OFF.

Is there a way to bypass the EEPROM and to load by default the EMMC cape ?
The u-boot seems to be OK with it, it is assuming we are using a BBB, but the kernel is not.

I’m actually going through the kernel compilation, i’m afraid that I can’t avoid it.
Does someone have any experience on this ?

Thank you in advance,

Julien Erdogan