Loaded Angstrom 2013-06-20, cannot log in

OK, started out with a fresh BeagleBoard black. It appeared to boot successfully, LEDs look appropriate. Plug in the USB and got
a gadget interface on it. The network came up and worked fine, I could ping it, go to the web server, etc. All fine.

But, when I attempted to ssh to the device, it would accept the connection, then drop the connection immediately.

So, I downloaded the current version of the Angstrom build. Programming seemed to go correctly, got to all 4 LEDs on solid. Rebooted
and now I don’t get a web service. I attempted to “ssh root@”, and ssh exchanged host keys OK, but the documentation
seems to claim that there is no root password. Normally, that would mean that ssh would not ask for a password, but in fact it is
asking for one. Tried a few possibilities with no success. So, how does one go about logging into the system??

marcus hall




In the past, I believe if was possible to ssh in as a regular user, then elevate yourself ( su ), change the root passwd, then upon future attempts it would work.

OK, this was a rather embarrassing error… The BBB is at, my own system was at, which is why I couldn’t ssh as root (it’s disabled!) When I ssh to the correct address, it works correctly. http service is also working properly.

Moved the system to an ethernet network and all works there too.

Still don’t know why the version that was delivered did an immediate disconnect after accepting an incoming connection, but after updating to the
current software it all works properly, so I don’t really care all that much…

marcus hall