Micro SDXC card in BB AI-64 gives black screen and only flashing light.

BB AI-64 won’t boot, only power LED is on. I flashed an SD card, when I insert it into the board power LED and first LED heartbeat flashing only, can’t ssh or use as standalone computer

What did you flash the SD card with ?

To boot from SD you need to remove power, then hold down the boot button and then re-apply power. and the release the button.

Just doing a reset will not work as the boot pin is only sampled at power on.

What SD card are you using. Some people have had issues with some brands of SD card, so if you can try another it would be a good idea.

Yes, I press boot then release when power is applied. I’m using a Kingston SD card 64GB. I used the latest image to flash it with balenaEtcher followed the instructions on getting started :confused: . But the problem is I only tried to boot from an SD card because my BB won’t boot on eMMC after a kernel upgrade, only power LED is on and it’s not detected on my laptop or as a standalone computer

which specifically…


11.3 debian and also tried 11.5

the date and the pre-fix to the file is the most importants bits…

Anywho… Grab this image from yesterday: https://rcn-ee.net/rootfs/bb.org/testing/2023-02-01/bullseye-minimal-arm64/bbai64-emmc-flasher-debian-11.6-minimal-arm64-2023-02-01-4gb.img.xz It’s pretty small, just to see what’s up… Use etcher.io to flash it to a microSD and then follow:

  • Insert microSD
  • Apply Power
  • Use your Finger nails, and hold BOTH RESET and BOOT Buttons
  • Let go of RESET
  • LED should start flashing
  • Let go of BOOT
  • Should start flashing the eMMC.


Thank you @RobertCNelson I’ll try this right now. Does the sd card need to be in a specific format? I read on this forum that if its 64gb I should re-format to exFat?

That doesn’t matter… Once you run balenaEtcher, it’ll fully erase the microSD with your chosen image file.


I get this output after following the instructions.

mmc: -110, grab a different microSD and try again… While it might not like it today, it maybe fixed later…


1 Like

Tried with 4GB Kingston SDHC card and it worked. Thanks!

will it be possible to give url for boot image which I can use to flash emmc on BB-AI64


Hi @Alok_Kumar_Mishra those are here: Debian 11.x (Bullseye) - Monthly Snapshots (ARM64)