Missing Usb0 interface booting from SD Ubuntu 14.04

Hi there,

Hope someone can help. I've just downloaded the SD image of Ubuntu 14.04 LTS for Beaglebone Black from here:


When I boot however, usb0 doesn't seem to initialise as the board isn't detected by the PC and it is not shown when ifconfig -a is run.

Based on other posts I've found for disabling the device, I've checked for references in /opt/scripts/boot/am335_evm.sh and can't find anything obvious but being new to Linux am not entirely sure what I'm looking for.

Usb0 and ip details are showing in network interfaces config.

Thanks in advance for your help.

Have you enabled the g_ether module?

I've not enabled it myself as I thought the usb0 interface would work straight from the image. I've done some searching online today about how to enable it in Ubuntu but perhaps not searching the right terms, can you offer a few pointers?


You'll want to enable or install the g_ether kernel module, and then create the interface for usb0.

It's for sure enabled on the provided Debian images, but it probably isn't on the other distros.

Thanks, beginning to get there. I ran lsmod which confirmed that g_ether isn't loaded.

I then located the module in the library under:


When I run insmod to load the module however, I get an error "No such device"

I'm going on the basis of a number of posts online which don't necessarily relate to Ubuntu, am I doing the right thing?

Sorry, my lack of Linux knowledge let me down, I was running insmod FILEPATH/g_ether.ko instead of going to the directory and running insmod.

I've done that now but get a new error about an unknown symbol in the module.

Can you try modprobe ‘g_ether’ and adding g_ether to /etc/modules?

Thanks for the above. When I go to the library folder and run modprobe g_ether I received a cannot insert error: operation not permitted. I then forgot I wasn't logged in as root so appended sudo but received the error "No such device" even although it's listed.

Tried to copy g_ether.ko to /etc/modules but it appears there is not a modules folder under /etc. Is it likely to be somewhere else under this distro?