Mystery: Beaglebone Black doesn't respond ping or ssh regularly

I have my BBB connected to a ADSL modem/router in bridged mode, so BBB gets directly an external IP. But sometimes, actually many times an hour, it doens’t respond to any protocol: I have tried pinging, ssh and http-request but nothing reaches BBB (connection timeout). However, I have set a crontab for dynamic dns service to update external IP of BBB with 15 min interval, when BBB tells its IP to the dyndns-service (I am 100 % sure that the IP address hasn’t been changed during the 15 minutes period, so connection should work).
After this I am able to connect again to the BBB.

The connection seems to “freeze” many times between dyndns-updates. In an hour there are four updates, and the conncetion loss occurs 0-4 times during that time.
What makes this a mystery is that there are no error logs in the BBB about connections. Its ethernet connector LED’s are on, but not blinking when I try to connect during the loss.

I have tried 2 Linux distributions, Arch and Debian Wheezy, and the problem exists with both.
I don’t know if this is a software or hardware issue. Sadly, I am not able to connect a screen, mouse or keyboard to the BBB so I can’t “look under the hood” during the problem.

Have the same problem, and it looks like “dropbear” crashes from time to time.
My application is connecting to the Internet about once every five minuites,
and this works, but ssh’ing in fails occasionally

I now run a script in the background which restarts dropbear, if it has crashed

though “systemctl restart dropbear”

This script will check about once a minute.

I do not have dropbear, I’m using openssh. Are you able to ping to your BBB when the problem exists?
If you can’t, you have the same situation as I do.

Did you test, if your BBB is still connected to the www while he is
not accessible? eg with a cronjob, something like:
* * * * * ping -c 1 >> /some_path_to/ping.log

maanantai, 6. tammikuuta 2014 14.19.59 UTC+2 Dieter Wirz kirjoitti:

Did you test, if your BBB is still connected to the www while he is
not accessible? eg with a cronjob, something like:

Works fine with 1 minute interval, no errors.
The ping crontab works as the dynamic dns updater, since I am able to ping and ssh my BBB after the crontab excecution. With 1 minute interval, there are no connection problems at all.

This ping crontab may be a temporary solution to the problem, but something is wrong blatantly.
Here’s a summary: if BBB has been connected to somewhere just a moment ago, I can connect to it. But when BBB’s internet connection has been idle for a few minutes, it won’t respond my requests until next dns/ping crontab execution.


..ooOO IIRC Arch and Debian have conman as default network connection
manager. But in a setup you have IMHO conman is *not* the ultimate
solution (conman may be great for laptops, etc). Did you have a look
at conman's log files? They tend to be *not* in /var/log depending on
your system.

I would try the following:
- Inactivate / Uninstall conman
- edit /etc/network/interfaces
- start the connections with "ifup eth0"