need help:: usb and ethernet not working on BB-XM


I've just bought a BB-XM and want to use it for ROS, so I downloaded
the pre-installed ubuntu 11.04 image and loaded it but the usb port is
not working so I couldn't connect a keyboard or mouse for the
configuration, I downloaded the headless version and loaded it,
however again the usb port is not working, there is no power at the
port and lsusb returns only the hub, also ifconfig only returns lo
with no eth0 and no leds light up at the port or anything if I plug an
ethernet cable

I've tried to download Angstrom as well but still no hope, only with
Angstrom the new thing here is that the usb host power led turns on
during the boot only then turns back off, while in ubuntu it was
always on but without actual power at the port (i think the led just
indicates the hub is powered)

is there like any soft flags that needs to be set within linux to
enable the devices or initiate it or something??

here is what lsusb and ifconfig returns in Angstrom for reference

I have the same issue. let me know if you find out what is causing

Check the u-boot version … the older version of u-boot doesnt support the USB EHCI … :

In case you wish to download the Ubuntu 11 prebuilt image with the USB support then you might consider this :