Need help with a Bullseye BBB image: some files not flashed and other questions.

Starting from this image i’ve created an image for a BBB running a “kiosk” application.
I have some “unsolved problems” of various importance, and i’d need some help.

  1. I did a bunch of tiny customizaton while booting from the microSD, and finally flashed it. But i’m missing some files/folder on the emmc:
    a: a “usb” folder in /media, which is where my app mounts USB dongles
    b: the fstab file (which contains a line that grants to the default user access to said folder)
    c: two executable files i’ve put in /usr/bin
    Why these files are not copied to emmc? what should i do?

  2. To flash, i’ve uncommented the last line in /boot/uEnv.txt. At boot appears the penguin logo but no messages, text, advancement… nothing. You just have the “supercar” pattern on the leds until the BBB shut down.
    Now; i’ve commented some optional lines in /etc/pam.d/login to obtain a silent boot: is it related? if not, why is the flashing procedure so silent?

  3. Conversly, i would like to see the penguin logo at (normal, not flashing) boot, but there’s just the blinking cursor, and i was not able to find how to make the penguin appears. What should i do?


/media is usally the auto-mount directory, so i have flagged it in the flasher to ignore… repos/beagle-flasher at master · rcn-ee/repos · GitHub

/usr/bin/rsync -aHAXx --human-readable --info=name0,progress2 /* /tmp/rootfs/ --exclude={/dev/*,/proc/*,/sys/*,/tmp/*,/run/*,/mnt/*,/media/*,/lost+found,/lib/modules/*,/uEnv.txt}

fstab just get’s autogenerated: repos/beagle-flasher at master · rcn-ee/repos · GitHub

	echo "# /etc/fstab: static file system information." > /tmp/rootfs/etc/fstab
	echo "#" >> /tmp/rootfs/etc/fstab
	echo "${destination}p${media_rootfs}  /  ext4  noatime,errors=remount-ro  0  1" >> /tmp/rootfs/etc/fstab
	if [ "x${media_rootfs}" = "x2" ] ; then
		echo "${destination}p1  /boot/firmware vfat defaults 0 0" >> /tmp/rootfs/etc/fstab
	echo "debugfs  /sys/kernel/debug  debugfs  mode=755,uid=root,gid=gpio,defaults  0  0" >> /tmp/rootfs/etc/fstab

Your binary in /usr/bin/ should have been transferred over…

Usually the quiet bootarg is enabled, this makes the console pretty quiet while flashing…


Sorry, i may not understand this:
Aren’t all the message="..." ; broadcast meant to be shown?
If not, as the old image i was using ( a debian 10 from 2017) always shown that messages, which are useful to check how it’s going, how should i enable them again, now?

Could the flasher script check for some additional script to run, or some option file in a predefined folder, or have i to modify it to get what i need?

  1. How can i show the penguin logo during the normal boot?