Network problem on BeagleBone compiled with the beaglebone-3.2.21-xenomai-2.6.2 kernel

I just tried Yogi Patel’s instructions for building the the xenomai kernel and after getting the kernel to boot, and the debugger to run I still couldn’t get a socket server on the beagle to accept connections from the outside world… It worked just fine with the Arago pre-built. So I don’t have any insights, but I’m seeing a network problem with my beaglebone-xenomai as well.

Guys -

Yes, there is a bug in my kernel somewhere for properly booting the network config.

One way to fix this is run:

$ ifconfig eth0 down
$ ifconfig eth0 up
$ ifconfig

This will solve your problem (for now).

I am currently occupied with getting the 3.8 kernel working with Xenomai for BeagleBone black


Did you run those ifconfig commands while being SSHed into your BB?

If so, crashing is expected because you’re shutting down Ethernet port.

You need to screen into your BB, run the ifconfig commands I sent you, and proceed from there.

Those commands should not cause a problem with crashing…