Network problem with Debian 10.3 IoT Image

I decided to take a look at the 10.3 image and right off the bat the network does not work.

After booting the board I am unable to ping anything on my network. Everything comes up as “Destination Host Unreachable”.

The strange thing is, I am able to ping and ssh to the board from another machine on the network.

The only thing I can find is the routing table looks odd:
$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
192.168.0.0 0.0.0.0 255.255.254.0 U 0 0 0 eth0
192.168.1.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0
192.168.6.0 0.0.0.0 255.255.255.0 U 0 0 0 usb1
192.168.7.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0

On another BeagleBone with a 9.13 image, the route looks like this:
~$ sudo route
[sudo] password for debian:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.6.0 0.0.0.0 255.255.255.252 U 0 0 0 usb1
192.168.7.0 0.0.0.0 255.255.255.252 U 0 0 0 usb0

Does anyone know where the routes are setup in Debian 10?

Thanks

Hi @bigguiness please re-test with:

https://rcn-ee.net/rootfs/bb.org/testing/2021-08-23/buster-iot/

Regards,

Robert,

Same result with the 10.10 image.

~$ cat /etc/dogtag
BeagleBoard.org Debian Buster IoT Image 2021-08-23

~$ ifconfig
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.1.23  netmask 255.255.254.0  broadcast 192.168.1.255
        inet6 fe80::c6f3:12ff:fe6a:1838  prefixlen 64  scopeid 0x20<link>
        ether c4:f3:12:6a:18:38  txqueuelen 1000  (Ethernet)
        RX packets 159  bytes 30864 (30.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 353  bytes 40401 (39.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 55

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 335  bytes 28594 (27.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 335  bytes 28594 (27.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.7.2  netmask 255.255.255.0  broadcast 192.168.7.255
        ether c4:f3:12:6a:18:3a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.6.2  netmask 255.255.255.0  broadcast 192.168.6.255
        ether c4:f3:12:6a:18:3e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.254.0   U     0      0        0 eth0
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0        0 eth0
192.168.6.0     0.0.0.0         255.255.255.0   U     0      0        0 usb1
192.168.7.0     0.0.0.0         255.255.255.0   U     0      0        0 usb0

~$ ping -c4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.23 icmp_seq=1 Destination Host Unreachable
From 192.168.1.23 icmp_seq=2 Destination Host Unreachable
From 192.168.1.23 icmp_seq=3 Destination Host Unreachable
From 192.168.1.23 icmp_seq=4 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 86ms
pipe 4

But, another machine can ping the board and I can ssh to it.

Humm…

debian@bbb-pwr01-ser09:~$ uname -r
4.19.94-ti-r65
debian@bbb-pwr01-ser09:~$ sudo route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
dns.google      192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
dns.google      192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.252.0   U     0      0        0 eth0
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0        0 eth0
192.168.6.0     0.0.0.0         255.255.255.0   U     0      0        0 usb1
192.168.7.0     0.0.0.0         255.255.255.0   U     0      0        0 usb0
debian@bbb-pwr01-ser09:~$ sudo ping -c4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.395 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.375 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.355 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.376 ms

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 0.355/0.375/0.395/0.019 ms

idk, everything looks the same…

and connman:

debian@bbb-pwr01-ser09:~$ journalctl | grep connman
Aug 27 17:21:10 bbb-pwr01-ser09 connmand[1070]: Connection Manager version 1.36
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: Checking loopback interface settings
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: System hostname is bbb-pwr01-ser09
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: lo {newlink} index 1 address 00:00:00:00:00:00 mtu 65536
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: lo {newlink} index 1 operstate 0 <UNKNOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: can0 {newlink} index 2 address 00:00:00:00:00:00 mtu 16
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: can0 {newlink} index 2 operstate 2 <DOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: can1 {newlink} index 3 address 00:00:00:00:00:00 mtu 16
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: can1 {newlink} index 3 operstate 2 <DOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {create} index 4 type 1 <ETHER>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {update} flags 4098 <DOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 address C8:A0:30:AB:F3:66 mtu 1500
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 operstate 2 <DOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 dbus-daemon[1058]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.6' (uid=0 pid=1070 comm="/usr/sbin/connmand -n --nodnsproxy ")
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: Adding interface eth0 [ ethernet ]
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {update} flags 36931 <UP,RUNNING>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 address C8:A0:30:AB:F3:66 mtu 1500
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 operstate 0 <UNKNOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {update} flags 36867 <UP>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 address C8:A0:30:AB:F3:66 mtu 1500
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 operstate 2 <DOWN>
Aug 27 17:21:12 bbb-pwr01-ser09 connmand[1070]: The name net.connman.vpn was not provided by any .service files
Aug 27 17:21:14 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route fe80:: gw :: scope 0 <UNIVERSE>
Aug 27 17:21:14 bbb-pwr01-ser09 connmand[1070]: eth0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Aug 27 17:21:14 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 address C8:A0:30:AB:F3:66 mtu 1500
Aug 27 17:21:14 bbb-pwr01-ser09 connmand[1070]: eth0 {newlink} index 4 operstate 6 <UP>
Aug 27 17:21:14 bbb-pwr01-ser09 connmand[1070]: Failed to set domainname to gfnd.rcn-ee.org
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} address 192.168.3.21/22 label eth0 family 2
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 192.168.0.0 gw 0.0.0.0 scope 253 <LINK>
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 8.8.8.8 gw 192.168.1.1 scope 0 <UNIVERSE>
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 8.8.4.4 gw 192.168.1.1 scope 0 <UNIVERSE>
Aug 27 17:21:15 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: eth0 {add} route 82.165.8.211 gw 192.168.1.1 scope 0 <UNIVERSE>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {create} index 5 type 1 <ETHER>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {update} flags 4098 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 address 00:00:00:00:00:00 mtu 1500
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb0 (filtered)
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Adding interface usb0 [ gadget ]
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 address C8:A0:30:AB:F3:68 mtu 1500
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb0 (filtered)
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {create} index 6 type 1 <ETHER>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {update} flags 4098 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 address 00:00:00:00:00:00 mtu 1500
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb1 (filtered)
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Adding interface usb1 [ gadget ]
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 address C8:A0:30:AB:F3:6C mtu 1500
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 27 17:21:16 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb1 (filtered)
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb0 {add} address 192.168.7.2/24 label usb0 family 2
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb0 {update} flags 4099 <UP>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 address C8:A0:30:AB:F3:68 mtu 1500
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb0 (filtered)
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb0 {add} route 192.168.7.0 gw 0.0.0.0 scope 253 <LINK>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {add} address 192.168.6.2/24 label usb1 family 2
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {update} flags 4163 <UP,RUNNING>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 address C8:A0:30:AB:F3:6C mtu 1500
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 operstate 0 <UNKNOWN>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb1 (filtered)
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {add} route 192.168.6.0 gw 0.0.0.0 scope 253 <LINK>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {update} flags 4099 <UP>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 address C8:A0:30:AB:F3:6C mtu 1500
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 27 17:21:17 bbb-pwr01-ser09 connmand[1070]: Ignoring interface usb1 (filtered)
Aug 27 17:21:33 bbb-pwr01-ser09 connmand[1070]: eth0 {del} route 82.165.8.211 gw 192.168.1.1 scope 0 <UNIVERSE>

Regards,

Strange. Definitely doe not work on my setup.

Questions…

If eth0 is 192.168.1.x, why is there a route for 192.168.0.0?
Why are the 192.168.0.0 netmasks different between our setups?
Why is the 192.168.1.1 netmask 255.255.255.255? Shouldn’t it be 255.255.255.0?
Why would I be missing the dns.google routes?

Thanks

BTW, I’m not familiar with how connman works so I’m not sure how to debug that output.

FWIW, here is the connman debug:

$ journalctl | grep connman
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {create} index 5 type 1 <ETHER>
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {update} flags 4098 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 address 00:00:00:00:00:00 mtu 1500
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: Ignoring interface usb0 (filtered)
Aug 23 10:36:06 beaglebone connmand[1046]: Adding interface usb0 [ gadget ]
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 address C4:F3:12:6A:18:3A mtu 1500
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: Ignoring interface usb0 (filtered)
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {create} index 6 type 1 <ETHER>
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {update} flags 4098 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {newlink} index 6 address 00:00:00:00:00:00 mtu 1500
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: Ignoring interface usb1 (filtered)
Aug 23 10:36:06 beaglebone connmand[1046]: Adding interface usb1 [ gadget ]
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {newlink} index 6 address C4:F3:12:6A:18:3E mtu 1500
Aug 23 10:36:06 beaglebone connmand[1046]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: Ignoring interface usb1 (filtered)
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {add} address 192.168.7.2/24 label usb0 family 2
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {update} flags 4099 <UP>
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 address C4:F3:12:6A:18:3A mtu 1500
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 23 10:36:06 beaglebone connmand[1046]: Ignoring interface usb0 (filtered)
Aug 23 10:36:06 beaglebone connmand[1046]: usb0 {add} route 192.168.7.0 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {add} address 192.168.6.2/24 label usb1 family 2
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {update} flags 4163 <UP,RUNNING>
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {newlink} index 6 address C4:F3:12:6A:18:3E mtu 1500
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {newlink} index 6 operstate 0 <UNKNOWN>
Aug 23 10:36:07 beaglebone connmand[1046]: Ignoring interface usb1 (filtered)
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {add} route 192.168.6.0 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:07 beaglebone connmand[1046]: Terminating
Aug 23 10:36:07 beaglebone connmand[1046]: Remove interface eth0 [ ethernet ]
Aug 23 10:36:07 beaglebone connmand[1046]: Remove interface usb0 [ gadget ]
Aug 23 10:36:07 beaglebone connmand[1046]: Remove interface usb1 [ gadget ]
Aug 23 10:36:07 beaglebone connmand[1046]: eth0 {remove} index 4
Aug 23 10:36:07 beaglebone connmand[1046]: usb0 {remove} index 5
Aug 23 10:36:07 beaglebone connmand[1046]: usb1 {remove} index 6
Aug 23 10:36:07 beaglebone connmand[1046]: Exit
Aug 23 10:36:07 beaglebone systemd[1]: connman.service: Succeeded.
Aug 23 10:36:11 beaglebone connmand[2444]: Connection Manager version 1.36
Aug 23 10:36:12 beaglebone connmand[2444]: Checking loopback interface settings
Aug 23 10:36:12 beaglebone connmand[2444]: System hostname is beaglebone
Aug 23 10:36:12 beaglebone connmand[2444]: lo {newlink} index 1 address 00:00:00:00:00:00 mtu 65536
Aug 23 10:36:12 beaglebone connmand[2444]: lo {newlink} index 1 operstate 0 <UNKNOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: can0 {newlink} index 2 address 00:00:00:00:00:00 mtu 16
Aug 23 10:36:12 beaglebone connmand[2444]: can0 {newlink} index 2 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: can1 {newlink} index 3 address 00:00:00:00:00:00 mtu 16
Aug 23 10:36:12 beaglebone connmand[2444]: can1 {newlink} index 3 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {create} index 4 type 1 <ETHER>
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {RX} 25 packets 6579 bytes
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {TX} 84 packets 11662 bytes
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {update} flags 36866 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {newlink} index 4 address C4:F3:12:6A:18:38 mtu 1500
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {newlink} index 4 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone dbus-daemon[1045]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.9' (uid=0 pid=2444 comm="/usr/sbin/connmand -n --nodnsproxy ")
Aug 23 10:36:12 beaglebone connmand[2444]: Adding interface eth0 [ ethernet ]
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {create} index 5 type 1 <ETHER>
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {update} flags 4099 <UP>
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {newlink} index 5 address C4:F3:12:6A:18:3A mtu 1500
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {newlink} index 5 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: Ignoring interface usb0 (filtered)
Aug 23 10:36:12 beaglebone connmand[2444]: Adding interface usb0 [ gadget ]
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {create} index 6 type 1 <ETHER>
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {update} flags 4099 <UP>
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {newlink} index 6 address C4:F3:12:6A:18:3E mtu 1500
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {newlink} index 6 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: Ignoring interface usb1 (filtered)
Aug 23 10:36:12 beaglebone connmand[2444]: Adding interface usb1 [ gadget ]
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {RX} 25 packets 6579 bytes
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {TX} 84 packets 11662 bytes
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {update} flags 36867 <UP>
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {newlink} index 4 address C4:F3:12:6A:18:38 mtu 1500
Aug 23 10:36:12 beaglebone connmand[2444]: eth0 {newlink} index 4 operstate 2 <DOWN>
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {add} address 192.168.7.2/24 label usb0 family 2
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {add} address 192.168.6.2/24 label usb1 family 2
Aug 23 10:36:12 beaglebone connmand[2444]: usb1 {add} route 192.168.6.0 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:12 beaglebone connmand[2444]: usb0 {add} route 192.168.7.0 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:12 beaglebone connmand[2444]: The name net.connman.vpn was not provided by any .service files
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {add} route fe80:: gw :: scope 0 <UNIVERSE>
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {RX} 25 packets 6579 bytes
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {TX} 84 packets 11662 bytes
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {newlink} index 4 address C4:F3:12:6A:18:38 mtu 1500
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {newlink} index 4 operstate 6 <UP>
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {add} address 192.168.1.23/23 label eth0 family 2
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {add} route 192.168.0.0 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>
Aug 23 10:36:14 beaglebone connmand[2444]: eth0 {add} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Aug 23 10:36:25 beaglebone connmand[2444]: IPv4 online check failed for 0x110d4e8 Wired

FYI, I don’t get dns.google routes either, but everything works.

Interesting that your netmask is 255.255.254.0, mine is 255.255.255.0
inet 192.168.1.23 netmask 255.255.254.0 broadcast 192.168.1.255

Things that have bitten me before,
two devices with the same host name on the network,
bad cables, switches. (reboot the switch sometimes helps)
the need to reboot the router (why, IDK, just that it has fixed issues in the past)

Ugh… Ok the inability to ping 192.168.1.1 ended up being a configuration option in my router. It was setup to not respond to pings. The netmask of 255.255.254.0 is also setup in my router. I forgot I did that a long time ago to separate the IoT stuff (thermostats, alarm, etc.) in my house from “normal” connections.

But, I am still unable to ping or access anything on the internet.

I disabled the USB networks in the /etc/default/bb-boot file to try and simplify everything a bit.

$ ifconfig
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.1.23  netmask 255.255.254.0  broadcast 192.168.1.255
        inet6 fe80::c6f3:12ff:fe6a:1838  prefixlen 64  scopeid 0x20<link>
        ether c4:f3:12:6a:18:38  txqueuelen 1000  (Ethernet)
        RX packets 1614  bytes 191792 (187.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2324  bytes 198510 (193.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 55

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1085  bytes 102230 (99.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1085  bytes 102230 (99.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

That looks correct to me.

$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.254.0   U     0      0        0 eth0
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0        0 eth0

I still don’t get why the 192.168.0.0 route is there or why the 192.168.1.1 mask is 255.255.255.255 instead of 255.255.254.0. But I can ping the local network and ssh works so…

It seems like the dns is not setup correctly. But the only thing I know about that is the /etc/resolv.conf file:

$ cat /etc/resolv.conf
# Generated by Connection Manager
nameserver 192.168.1.1

I’m not sure if that’s right or not…

Any ideas?

see inserted comments,

Update…

I moved my BeagleBone to a VPN network I have that is behind my 192.168.1.x network and now am able to ping stuff on the internet. Also, apt get update now works.

Works - BeagleBone → hardware VPN → Router → Internet
Fails - BeagleBone → Router → Internet

I’m not sure what the problem is with my main network and the 10.3 IoT image. I have a number of boards with an old Debian 9 console image on them an they work fine.

Oh well… This issue is beyond my pay grade…