Networking/internet issues

(I posted this before, but I wasn’t a member of the group then, so I deleted that post, joined the group, and am posting this again. Apologies if this is seen as spam.)


This post is actually with regards to the SanCloud BeagleBone Enhanced, but there doesn’t seem to be a specific forum for that board, so I’m posting to its closest relative, the BeagleBone Black.

I’ve been having trouble getting Internet to my BeagleBone, which is running the latest image (Debian 9.4 2018-06-17 4GB SD IoT). Please note that the WiFi card installed on this board simply does not work, as far as I know, so that’s not an option. I can get Internet if I simply attach it via Ethernet directly to my router, but that is not ideal since I move locations a fair amount. Ideally, I need to share my laptop’s WiFi connection to the BeagleBone, either over USB or Ethernet. (My laptop runs Ubuntu 18.04)

One major roadblock is that the web server (not sure if that’s the appropriate term) doesn’t seem to boot up correctly when the board is powered on and connected to my laptop. I get a notification on my laptop that says “Network activation failed” or something to that effect, which is usually accompanied by my desktop (GNOME) crashing and restarting. Afterwards, the classic doesn’t work. Can’t SSH in, and visiting on my laptop’s browser returns a timeout. The only way I can actually get into the BeagleBone is by using screen and going into /dev/ttyACM0. And ifconfig on my laptop shows that the BeagleBone has some incredibly long and weird registered name, not the eth[#] that it usually is.

That’s the first problem. The second problem is that I’m not sure how to share my laptop’s Internet connection, since I’m pretty new to Linux. I’ve tried following this guide, but that doesn’t work, and various futzing around with sharing over Ethernet in nm-connection-editor doesn’t work either. I’m assuming that the fundamental problem here is the first thing I described – the failure of the BeagleBone’s web server – which in turn is causing these auxiliary failures with my Internet sharing.

Anyone have similar issues or have any suggestions? Thanks in advance for any responses!

It looks like your PC is having some network driver issues, try on another PC once to cross check the working status of BeagleBone.

I have the wifi working on mine using the 4.14.55-bone16 kernel and the kernel drivers/firmware. That said, I think there is an antenna issue or something. I snagged an antenna off my BBGW and plugged into the little port and its still very picky about location. Depending on where I move it around, it won’t pick up the access point.


An update:

In the end, I ended up just kind of circumventing the whole issue. I decided to reflash my board and start all over, and this time sharing my Ethernet connection using nm-connection-editor worked for whatever reason. I then gave the BeagleBone a static IP address as per the instructions in this thread and can now SSH in.

The problem with “Network activation failed” still persists, but I don’t really care that much anymore since it works. Thanks to everyone!