New BBB, PuTTy SSH and serial connection troubles

Hi guys,
I just got myself a second Beaglebone Black and with the first one I’ve never have this kind of problem.
I installed the drivers as per the Getting-started guide, PuTTy, connected the beagle using the USB cable and setted the sharing connection (my pc is connected via wifi) properties between my notebook (Windows 8.1) and the bb.

Following Derek Molloy book I tried with the serial connection first, and I’m able to (at least) log in:

uname -r
3.8.13-bone47 (I’m waiting for the last image dowload to end)
ifconfig usb0
usb0 Link encap:Ethernet HWaddr 5a:be:06:e3:39:ed
inet addr: Bcast: Mask:
inet6 addr: fe80::58be:6ff:fee3:39ed/64 Scope:Link
RX packets:794 errors:0 dropped:0 overruns:0 frame:0
TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:213169 (208.1 KiB) TX bytes:13470 (13.1 KiB)

/sbin/route add default gw
echo “nameserver” >> /etc/resolv.conf
i try to ping but i get this error:

From icmp_seq=1 Destination Host Unreachable.

I tried using the SSH connection as well and in this case i got a PuTTy fatal error: Network error: connection timed out.

Any idea why is that?
Thanks in advance.