New microSD card w/ BeagleBone

I recently purchased a BeagleBone and am trying to get the Angstrom/
Cloud9 installation working on a 32GB microSD card. Here is my
experience so far:

I'm running Ubuntu 10.04.

The 2GB card that came with the bone works fine. When I plug the USB
into my computer and ethernet cable to my network router, a device
called BEAGLE_BONE mounts to my system. When I eject it, the
BeagleBone is accessible on my network. (Also, Banshee crashes and my
network hiccups a little. Thoughts?) I have ssh access to the bone,
and can access the cloud9 environment by navigating to Everything there seems to work fine. (Except when
I run "opkg update" I get a ton of "wget: bad address 'feeds.angstrom-' " errors. Pinging that address from the bone via ssh
works fine; about 46ms per ping.)

Now, I have a brand new 32GB PNY microSD(10) card. I followed the
instructions here (
beaglebone/), both the "easy way" and the "hard way" and things don't
work quite the same. When I follow the "easy way" instructions, the
card no longer auto-mounts in my Ubuntu system, and my system doesn't
react at all when the card in is the bone. I also cannot access the
cloud9 interface and have no ssh access to the bone. My router sees
the device with the same IP as above. When I do things the "hard way"
the card is visible to my system, but again no response from the bone.
(No ssh and no cloud9.)

I tried the following as a work around: I formatted the new microSD
card using the mkcard.txt script from the link above, and then copied
the files from the boot and cloud partitions of the demo card onto my
new card. This approach leads to the same response from my system as
the demo card does! I have ssh access and can access cloud9.

What is the *RIGHT* way to get everything working on a new microSD
card? Was I doing something wrong in following the instructions at ? If so, what
should I have done differently? I will also say that I tried following
the same "easy way" and "hard way" instructions with an 8GB SanDisk
microSD(2) card with no better luck.

Thanks for reading all of the above.

My experiences with 32GB SD cards have not been successful.
On the Beagleboard XM I got both Angstrom and Ubuntu installed on 2 cards but part way through upgrades they failed and would no longer boot.

I did fsck on the x86_64 boxes which said it was clean but both cards failed to boot on the XM - I tried 2 different readers.

No problems with 16GB SD cards on the XM.
I now run a laptop with Ubuntu x86_64 off one of the 32GB SD cards. The other 32GB card also worked without problems on the x86_64 laptop.