newbie-level questions on initial attempt at playing videos

having finally picked up an inexpensive flat panel display, i just
took my first crack at using gstreamer to play a video or two on my
beagleboard with a moderate amount of success, but i have a few
beginner-level questions so be gentle. all i want to do is get a
couple working examples under my belt, at which point it should be
easy to take it from there.

  the display is a 1600x900 gateway flat panel.

  first, i'm using felipe contreras' prebuilt kernel and root
filesystem from here:

  Index of /~felipec/beagle-2.6.32-rc3

i dumped the kernel and rootfs onto an SD card, booted to standard
u-boot and, since i'm still not clear on various video settings,
reproduced *exactly* what's in felipe's README file, even though i'm
sure it's not entirely appropriate for my display:

setenv bootargs console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw \

  rootdelay=1 devfs=mount omapfb.mode=dvi:1024x768MR-24@60 \

mmc init
fatload mmc 0 0x80300000 uImage
bootm 0x80300000

  that booted nicely, at which point i tried to play some sample
MPEG-4 files i downloaded from the net (from, all four of them). so:

# gst-launch playbin2 uri=file://$PWD/yu.mp4
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
WARNING: from element
/GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder
available for type 'audio/mpeg, mpegversion=(int)4,
framed=(boolean)true, codec_data=(buffer)1510, rate=(int)11025,
Additional debug info:
gsturidecodebin.c(633): unknown_type_cb ():
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Got EOS from element "playbin20".
Execution ended after 189315124499 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

Robert P. J. Day wrote:

# gst-launch playbin2 uri=file://$PWD/yu.mp4

   unsurprisingly, while the video played, it was pretty grainy and

that video IS grainy and low quality....

oh, i know it's not high-quality, but the quality being displayed on
the flat panel is even *worse*, i'm guessing because i should still
adjust the kernel video settings. playing that file on my host system
thru VLC doesn't look *too* bad, the flat panel definitely looks

  and almost certainly a silly question, but how can i examine the
detailed properties of an MPEG-4 file in linux? like, say, actual
resolution? i can play any of those files in VLC, but i can't see
anywhere in VLC i can ask for the attributes of what's playing.

  as a trivial example, if i use the standard "file" command on those
files, i get nothing but:

$ file *
yu2.mp4: ISO Media, MPEG v4 system, version 2
yu3.mp4: ISO Media, MPEG v4 system, version 2
yu5.mp4: ISO Media, MPEG v4 system, version 2
yu.mp4: ISO Media, MPEG v4 system, version 2

i guess what i'm saying is, it's time for me to start reading up on
basic video. i'm guessing there's a package of basic MPEG-4 utilities
around somewhere.


p.s. and i just lost the flat panel display again. argh.