nfs boot - no ssh keys

Hello,
My network boot and nfs are all working but I cannot ssh into the BBB. Looking in /etc/ssh there are no ssh_host* files - there are a few files and a ssh_regenerate.

Rootfs:
./RootStock-NG.sh -c eewiki_minfs_debian_jessie_armhf

kernel:
kernel_version=3.14.48-ti-r72

/etc/fstab
debugfs /sys/kernel/debug debugfs defaults 0 0

Do I need any scripts or configuration to enable the the regeneration of the ssh keys on first boot ?

thanks

Rob

Normally this script gets called on bootup:

https://github.com/RobertCNelson/boot-scripts/blob/master/boot/generic-startup.sh#L8

so just:

sudo dpkg-reconfigure openssh-server

Regards,

Thanks Robert,

Looking at the chroot.sh script in omap-image-builder, I see that that you copy this file to /etc/init.d/generic-boot-script.sh for Wheezy and Ubuntu but this is not done for Jessie/Stretch.
I have a custom cape and once this is installed I do not have access to serial debug cable, so having ssh run from the start is important for me.

All your scripts are installed in /opt so would it work if I just copy the script to /etc/init.d/ after I untar the the rootfs to nfs dir ?

Thank you for your work and support.

Rob

Thanks Robert,

Looking at the chroot.sh script in omap-image-builder, I see that that you
copy this file to /etc/init.d/generic-boot-script.sh for Wheezy and Ubuntu
but this is not done for Jessie/Stretch.

Yeah that was moved to "bb-customizations"...

Here's the systemd file..

https://github.com/RobertCNelson/omap-image-builder/blob/master/target/init_scripts/systemd-generic-board-startup.service

I should check and see if "bb-customizations" is in the deb package
line and add the above when not..

I have a custom cape and once this is installed I do not have access to
serial debug cable, so having ssh run from the start is important for me.

All your scripts are installed in /opt so would it work if I just copy the
script to /etc/init.d/ after I untar the the rootfs to nfs dir ?

Yeap.. just copy:

https://raw.githubusercontent.com/RobertCNelson/omap-image-builder/master/target/init_scripts/systemd-generic-board-startup.service

and

sudo systemctl enable systemd-generic-board-startup.service

Regards,

fixed going forward:

https://github.com/RobertCNelson/omap-image-builder/commit/6f5a0dfad65fbed091d2687fdb1e1d58e7c8bbf8

Regards,

Decided to update and rebuild - saw you already changed it :slight_smile:

Busy building now - thanks