NHD-7.0CTP-CAPE-N no picture

Hi all

I’m trying to use the New Haven NHD-7.0CTP-CAPE with my BBB.
But so far I have not been able to get a picture on the screen.
I have tried running the latest Debian 8.7 image (From BeagleBoard.org), Ubuntu 14.04 Kernel 3.8 and Ubuntu 16.04.2 kernel 4.4.59-ti-r96.

So far I have not been able to get a picture on the cape, but the HDMI works fine. I have tried to look in the device-tree to see if I could conclude weather or not the cape was recognized. But I don’t really know what to look for.

There must be other people out there that uses this cape, so what did you do to make it work, and what distribution are you running?

Thanks Rasmus.

Oh these are brand new:

http://www.newhavendisplay.com/development-tools-shields-and-capes-c-979_981.html?zenid=ihsl54v4p4fiu2rvr1b3eapd94

First i've seen of it, so yeah they aren't supported "this minute"..

Did they provide a CD or any documentation in the box? if so can you
dump it to dropbox and share it with me?

Regards,

Hi Robert

It came in a cardboard box with loads of bubble wrap. No CD, no documentation. The only thing I got is what is on their web page
http://www.newhavendisplay.com/nhd70ctpcapen-p-9537.html

I have tried the Ubuntu 14.04-3.8 image, but it didn’t give me a picture, and I couldn’t get it to flash either… :frowning:

I’m wondering if the BBB is reading the CAPE EEprom correct and if I could verify it in the device-tree.
I used this command in the terminal

find /proc/device-tree/ -type f -exec head {} + | less

It returns a really long list, But I can't seem to find any information about how the LCD pins a muxed...
But I'm also faily new to linux, so I don't really know what to expect...

Regards Rasmus

what does "dmesg | grep bone" show?

Regards,

I don’t know how to retrieve the text from the terminal but here goes…

[0.000000] Kernel command line: console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=UUID=1be96781-5260-4113-96e 3-7c97f1fde997 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 quiet cape_universial=enable
[2.469004] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,000C,1631BBBG0959’
[2.469040] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[2.469075] bone_capemgr bone_capemgr: slot #0: auto loading handled by U-Boot
[2.469098] bone_capemgr bone_capemgr: slot #1: auto loading handled by U-Boot
[2.469141] bone_capemgr bone_capemgr: slot #2: auto loading handled by U-Boot
[2.469169] bone_capemgr bone_capemgr: slot #3: auto loading handled by U-Boot
[2.469172] bone_capemgr bone_capemgr: initialized OK.

I think I would have expected to see something actualy loaded here…?

It is the only cape I have connected to my BBB.

Ah, the image your running has u-boot handling it, since you loose
physical access with the serial plugged in, that makes debugging fun.

In /boot/uEnv.txt

Change:

enable_uboot_overlays=1 -> #enable_uboot_overlays=1

and force:

dtb=am335x-boneblack-emmc-overlay.dtb

Then reboot again, and run dmesg | grep bone

Regards,

Hi Robert.

I get that you want me to out comment the enable line in uEnv.txt.
But do you want me to enter the second command to the bottom of the file or just run it at the command line?

Sorry but I’m quite new to linux…

/Rasmus

ohh…

I just saw that I have a
#dtb=
Line at the top of uEnv.txt
I guess I should add it there…?
and also is it suposed to be “dtb=am335x…” or should it be “dtb=arm335x…”? (since this is an arm processor)

/Rasmus

no just use:

dtb=am335x-boneblack-emmc-overlay.dtb

Regards

Hi Robert

I don’t know what I’m doing wrong but I have tried your instructions several times with the result that the BBB won’t boot.
It turns on the four LED and stop there. they keep being on all the time.

I use nano to edit the uEnv.txt file.

When I flash a new image I have the following

uname_r=4.4.59-ti-r96
#uuid=
#dtb=

###U-Boot Overlays###
###Documentation: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Overlays
###Master Enable
enable_uboot_overlays=1

no space between dtb= and am*

Regards,

Hi Robert

I could have sworn that space was a typo in the message.

anyway, now it boots and this is what I get from
dmesg | grep bone

ubuntu@arm:~$ dmesg | grep bone
[ 2.374724] bone_capemgr bone_capemgr: Baseboard: ‘A335BNLT,000C,1631BBBG0959’
[ 2.374760] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[ 2.413510] bone_capemgr bone_capemgr: slot #0: ‘nh7cape,A0,Cembsoft,BB-BONE-NH7C-01’
[ 2.453402] bone_capemgr bone_capemgr: slot #1: No cape found
[ 2.493583] bone_capemgr bone_capemgr: slot #2: No cape found
[ 2.533395] bone_capemgr bone_capemgr: slot #3: No cape found
[ 2.533636] bone_capemgr bone_capemgr: initialized OK.
[ 3.545642] bone_capemgr bone_capemgr: loader: failed to load slot-0 BB-BONE-NH7C-01:A0 (prio 0)
[ 30.019837] bone_capemgr bone_capemgr: part_number ‘univ-emmc’, version ‘N/A’
[ 30.019880] bone_capemgr bone_capemgr: slot #4: override
[ 30.019898] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[ 30.019914] bone_capemgr bone_capemgr: slot #4: ‘Override Board Name,00A0,Override Manuf,univ-emmc’
[ 30.593518] bone_capemgr bone_capemgr: slot #4: dtbo ‘univ-emmc-00A0.dtbo’ loaded; overlay id #0
ubuntu@arm:~$

So it looks as if the cape is recognized, but there is still no picture. I dont have HDMI either so currently I’m SSH’ing into it.
There is plenty of backlight in the display though…

Regards Rasmus

bingo! that's what i needed (eeprom value), i'll start working on a
patch as i found the schematic!

Regards,

Hi Robert

I finaly got this image to boot and give me a picture.
https://www.dropbox.com/s/n4hgu39ccskbl8c/ubuntu-14.04-3.8.img.gz?dl=0

it is one of the images that NHD links to in the user manual.

I can’t get it to flash to the eMMC though. but I gues that is a subject for another thread.

I would still be nice to know what it is that makes the display works on this image in case I want to upgrade at some point…

Thank you for your time you have been most help full. :slight_smile:

Regards Rasmus

Okay got this working, you'll need a u-boot build from today:

U-Boot SPL 2017.05-rc2-00002-g86566339a9 (Apr 28 2017 - 10:18:57)

and the latest version of the bb-cape-overlays debian package:
4.4.20170428-0rcnee1~jessie+20170428

(this sunday's snapshot will both of these ready for you)

https://paste.debian.net/929904/

with /boot/uEnv.txt

enable_uboot_overlays=1

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Overlays

Regards,

Hey, I am stuck at the same problem. Except, I am using a beaglebone black wireless. But that shouldn’t matter since everything is the same between the two boards. How did you get this to work? I have tried everything but nothing seems to work.

Let's see your kernel/bootloader configuration:

sudo /opt/scripts/tools/version.sh

Regards,

Hey Robert, thanks for responding promptly. Here is the output:

debian@beaglebone:~$ sudo /opt/scripts/tools/version.sh
git:/opt/scripts/:[2ce750d881941c5189db9e189af90517e11c079f]
eeprom:[A335BNLTBWA51650BBWG1172]
dogtag:[BeagleBoard.org Debian Image 2017-08-31]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot
2017.09-rc2-00002-g7c9353]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2016.11-rc3-00002-g73df7f]
kernel:[4.9.45-ti-r57]
nodejs:[v6.11.2]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_addr3=/lib/firmware/BB-BONE-NH7C-01-A0.dtbo]
uboot_overlay_options:[disable_uboot_overlay_emmc=1]
uboot_overlay_options:[disable_uboot_overlay_video=1]
uboot_overlay_options:[disable_uboot_overlay_audio=1]
uboot_overlay_options:[disable_uboot_overlay_adc=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-UIO-00A0.dtbo]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg:[bb-cape-overlays]:[4.4.20171126.0-0rcnee1~stretch+20171126]
pkg:[bb-wl18xx-firmware]:[1.20170829-0rcnee1~stretch+20170829]
pkg:[firmware-ti-connectivity]:[20170823-1rcnee0~stretch+20170830]
debian@beaglebone:~$

Your bootloader in the eMMC is too old, it's breaking U-Boot Overlays....

sudo dd if=/dev/zero of=/dev/mmcblk1 count=1 seek=1 bs=128k

Regards,

Thanks! It worked!
I still don't understand how it was booting off of the eMMC, because I
have the microSD inserted.
If I had re-flashed the bootloader using the instructions on the bbb
website, would it still have worked? or would I still have to apply
the fix you mentioned earlier?