No display on Samsung Syncmaster 970p

Hi list,

I asked this yesterday on the irc so it’s a bit redundant but I figured there’d be a point in posting here as well both for more people maybe having some input and also more seing this problem.

I’ve got two SD cards, one with angstrom-demo and one with debian-arm. Both boots fine and I can login via minicom without any problems. For some reason however my Samsung 970p refuses to display anything (except from the testing of analogue/digital input) and then goes to sleep.

The relevant output from Angstrom during boot is this:
omapfb: DISPC version 3.0 initialized
Console: switching to colour frame buffer device 128x48
omapfb: Framebuffer initialized. Total vram 1572864 planes 1
omapfb: Pixclock 54000 kHz hfreq 45.6081 kHz vfreq 57.7 Hz

And when starting X:
(**) FBDEV(0): Built-in mode “current”: 54.0 MHz, 45.6 kHz, 57.7 Hz
(II) FBDEV(0): Modeline "current"x0.0 54.00 1024 1104 1136 1184 768 783 787 790 -hsync -vsync -csync (45.6 kHz)
(==) FBDEV(0): DPI set to (96, 96)

With debian during boot I get:
Console: switching to colour frame buffer device 160x45
omapfb: Framebuffer initialized. Total vram 6291456 planes 2
omapfb: Pixclock 57600 kHz hfreq 40.0 kHz vfreq 53.9 Hz

And when starting X:
(–) FBDEV(0): Virtual size is 1280x720 (pitch 1280)
(**) FBDEV(0): Built-in mode “current”: 57.6 MHz, 40.0 kHz, 54.0 Hz
(II) FBDEV(0): Modeline "current"x0.0 57.60 1280 1360 1392 1440 720 733 738 741 -hsync -vsync -csync (40.0 kHz)

I tried setting the same modeline for my pc as was used in the beagleboard:
Modeline “current” 57.60 1280 1360 1392 1440 720 733 738 741 -hsync -vsync -csync
Modeline “current2” 54.00 1024 1104 1136 1184 768 783 787 790 -hsync -vsync -csync
And both of them resultet in the same black screen going to sleep.

On the irc I was told that the problem might be that my monitor can’t handle the output from the bb, can that really be the case? While writing this xvidtune reports that my current modeline (I’ve only got one monitor) is:
“1280x1024” 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync

I’ve tried playing around a bit with fbset but I still get the same darkness thrown at me. This is the output I get from fbdev when not giving any args:
mode “1280x720-54”

D: 57.600 MHz, H: 40.000 kHz, V: 53.981 Hz

geometry 1280 720 1280 720 16
timings 17361 48 80 3 13 32 5
rgba 5/11,6/5,5/0,0/0

Is there no way to change the resolution/timings of the framebuffer? Or am I forced to buy a new monitor to be able to see the video out from the bb? If that’s the case, is there any list of safe monitors so I don’t waste some hundred euro to keep gawking at darkness?


I’ve been wrestling this for a while now, with no progress. I’ve tested my beagle on three different monitors, and a friend who also have a bb have tried it with the same monitors and the same SD cards and for him they all work.

My tv-out works and I can read the edid from the monitors I’ve tried but I get no video out through the DVI. I think it’s a really strange problem since everything but the DVI out is working perfectly fine.

I guess my only option at this point is doing an RMA and go through the long process of sending it back to the US and hopefully getting a new working one in x weeks.

So, bb in general works fine with Samsung 970p, it’s just my beagle having problems.


If you think this is a DVI-D issue, go ahead and request an RMA. I am sure they will work something out with you to get the board turned around as quickly as possible.


More to inform other people of my pleasant experience with the
Beagleboard RMA people:

Turns out the DVI-D was broken, it's now replaced and on its way home
again. I'm really impressed by the responsiveness of the RMA-.people.
Received replies to my questions withing 10 minutes and unless fedex
screws up will the total time away from me be about 2 weeks, shipping
from Germany to the US, fixing and shipping back.