No MMC/USB recovery, beagle bricked?

Hello,

I am trying to recover a BeagleBoard rev C4. Until yesterday, it
booted fine from nand.
Since yesterday I don't get any activity in minicom any more, not even
"40T".
I don't recall having changed anything.

I have tried all the solutions presented in http://elinux.org/BeagleBoardRecovery
with no luck.

1/ MMC recovery
NOTE: Using my existing recovery card did not work.
I formated/reformated it
  * using the instruction on page http://code.google.com/p/beagleboard/wiki/BeagleboardRevC3Validation
  * using the mkcard.sh script found here http://www.angstrom-distribution.org/demo/beagleboard/

I also take care of erasing the first flash sector, to make sure MLO
is in the first flash sector after
formatting.

I used different MLO, including the recovery MLO, with no luck.

The result was always the same: booting with S1/userbutton pressed,
nothing happens on minicom
(it worked previously, so I assume communication parameters are fine)

2/ USB recovery
I followed the instructions presented here:
http://nishanthmenon.blogspot.com/2009/01/beagleboard-recovery-take-2.html

When using the script recover_beagle.sh found in
http://groups.google.com/group/beagleboard/web/beagle_recover.tar.bz2

I never got further than this:
  $ sudo ./recover_beagle.sh /dev/ttyUSB0
  [sudo] password for gilles:
  NOTE:
  When you see the message "Waiting for USB device..", Connect USB
Cable to the board with the switch S1 pressed
  Keep S1 pressed for 1 second at least after connecting usb cable.
  Waiting for USB device vendorID=0x451and productID=0xD009:

No USB device is detected!

3/ UART recovery
I also tried the pserial program from the above archive like this:
  $ sudo ./pserial -p /dev/ttyUSB0 -f ../u-boot.bin
  lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/
gilles/.gvfs
        Output information may be incomplete.</blockquote>
  Waiting For Device ASIC ID: Press Ctrl+C to stop
  Did not read asic ID ret = 1

I did not find anybody on this list which could not even manage to get
USB recovery working. Did I miss something or is this BeagleBoard
broken?

Thank you for any hint!

-- Gilles

Try the following link:

http://code.google.com/p/beagleboard/wiki/BeagleBoardDiagnosticsNext

Follw it to the letter and don’t take any shortcuts. We get “bricked” boards in on RMA from time to time and it always takes us about 45 seconds to unbrick it so if you follow the instructions, you should have no issue getting it recovered. MAke sure you follow the Rev C4 path on these instructions.

Gerald

2011/2/2 Gilles Grégoire <gilles.gregoire@gmail.com>

be sure not broken :slight_smile: I had same issue with rev c4 BB. I tried lots of different and same things again and again for Angstrom demo image. Then I changed uImage with rev c4 version, with it I could recover my BB but now other problems occured. So I decided to use Ubuntu Maverick version image. For this only I followed the instruction on elinux ubuntu page , now BB works finely, never tried to recover

2011/2/2 Gilles Grégoire <gilles.gregoire@gmail.com>

Did not saw this one, I am trying it... but this looks like a _very_
long procedure, with very long downloads, etc.

I have to admit that if my BeagleBoard is not bricked, this raises a
few question:
  * why would my (previously booting) emergency sdcard have stopped
working?
  * why is there _absolutely nothing_ happening on the console?
  * why is there _nothing_ happening when trying USB recovery?

Best regards,

-- Gilles

SD cards can get corrupted, especially if you turn power off or remove them without dismounting them. In a similar fashion, the on board NAND can get corrupted as well.

No console output can occur if the NAND is corrupted and it gets lost. You should be able to remove the SD card, hold the user button down, and then press and release the reset button. It should print something out that would look like garbage. If this is not happening, then the board may have experienced a more catastrophic event.

Gerald

2011/2/2 Gilles Grégoire <gilles.gregoire@gmail.com>

Thank you for your help. I think I have to return my BeagleBoard since
I do not even get garbage out using the manipulation you describe.

Morever, I could not manage to boot anything (still no output) using
the instructions of the link you provided earlier.

Thank you anyway!

I would request an RMA and get it fixed.

Gerald

2011/2/3 Gilles Grégoire <gilles.gregoire@gmail.com>

hi

I had the same problem with C4 ver beagle board
i too had tried all the procedures but with no luck until 2 days back

make sure you have formated the mmc card as described for beagle board
download only these files below and copy to the fat partion on the mmc
card
insert the mmc in the slot on the board

http://free-electrons.com/labs/beagle/u-boot.bin
http://free-electrons.com/labs/beagle/MLO

hold the user button and press reset button before turning on the
board.
turn on the board now
release the reset button first and then
and release the reset button and then the user button
the beagle will perform some tests by itself
you will get a u-boot prompt

then you will have to follow the procedure of writing u-boot on to the
flash
this is a standard procedure which i think you will be knowing

then the board will be ok

but i observed that with only these MLO and u-boot the C4 board works
fine
but if i use different files the board does not work..

so remember to use the same MLO and u-boot downloaded from the link
above
i then added the kernel uImage to the boot partion and Angstrom image
on to the linux partion and then booted angstrom linux without any
problem

if possible i will post the link describing all the steps

hi

check the procedure to unbrick the beagle board

download the file in the link below

http://free-electrons.com/doc/training/beagle/labs.pdf
follow the procedure given on page no 13 titled U-boot recovery