no serial console on angstrom demo

Hi, I am trying to run the angstrom demo from:
http://www.angstrom-distribution.org/demo/beagleboard/

I need a serial console for now because I don't have a monitor. I
want to set up ssh then connect to it over usb, but I think I need a
shell over serial console to do that.

It seems to boot, and I get a lot of messages on the serial console,
but I never get a login or shell.
I looked in the inittab file in the rootfs, and it seems to spawn a
getty by default for ttyS2.

When I plug in usb connected to another computer, I get a message on
the serial console:

usb0: high speed config #1: 8 mA, Ethernet Gadget, using CDC Ethernet

I also see usb0 on that computer with ifconfig. I edited the file
configuring the static ip for usb0, then I gave my other machine an ip
on the same subnet and tried to ping the beagle board with no luck.
Maybe it gets stuck before a login?

Thanks,
Sean

I loaded my REV B5 board using the 20080920 image from that location,
and I have had no problems with the serial console.

Like you, I do not have, and never had, a monitor attached to my
board.

I mostly followed the instructions for installing the Angstrom demo
from here:
http://code.google.com/p/beagleboard/wiki/HowToGetAngstromRunning

I say mostly because I did not copy the Angstom-...tar.bz2 file onto
the SD card before extracting the contents onto the second partition,
which I setup as an ext2 file system. I am also working from a native
install of Ubuntu 8.10, so I didn't do the vmware thing either.

-Preston

Hi,

I realized it worked but took several minutes to boot where it didn't
print anything and I was too impatient.

Sean