OE bitbake (mkimage) error in kernel compilation

Hi Folks,

I'm fairly new to Beagleboard, and am attempting to compile the
Angstrom distribution using OE bitbake. The command I'm running is
"bitbake x11-image" and I have the following error:

OE Build Configuration:
BB_VERSION = "1.8.13"
METADATA_BRANCH = "org.openembedded.dev"
METADATA_REVISION = "c838626c2b210596ad126944966b78b0c68ebf13"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "beagleboard"
DISTRO = "angstrom"
DISTRO_VERSION = "2009.X-test-20090417"
TARGET_FPU = "hard"

NOTE: Resolving any missing task queue dependencies
NOTE: preferred version git of u-boot not available (for item u-boot)
NOTE: preferred version git of u-boot not available (for item u-boot)
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 1245 of 4407 (ID: 623, /mnt/c/beagle/oe/
openembedded/recipes/linux/linux-omap_2.6.28.bb, do_compile)
NOTE: package linux-omap-2.6.28-r27: task do_compile: started
ERROR: function do_compile failed
ERROR: see log in /mnt/c/beagle/oe/tmp/work/beagleboard-angstrom-linux-
gnueabi/linux-omap-2.6.28-r27/temp/log.do_compile.4366
NOTE: Task failed: /mnt/c/beagle/oe/tmp/work/beagleboard-angstrom-
linux-gnueabi/linux-omap-2.6.28-r27/temp/log.do_compile.4366
NOTE: package linux-omap-2.6.28-r27: task do_compile: failed
ERROR: TaskFailed event exception, aborting
ERROR: Build of /mnt/c/beagle/oe/openembedded/recipes/linux/linux-
omap_2.6.28.bb do_compile failed
ERROR: Task 623 (/mnt/c/beagle/oe/openembedded/recipes/linux/linux-
omap_2.6.28.bb, do_compile) failed
NOTE: Tasks Summary: Attempted 1244 tasks of which 1244 didn't need to
be rerun and 1 failed.
ERROR: '/mnt/c/beagle/oe/openembedded/recipes/linux/linux-
omap_2.6.28.bb' failed
NOTE: build 200904172133: completed

Looking at the log file, it appears that mkimage is failing with the
following error:

make[2]: Leaving directory `/mnt/c/beagle/oe/tmp/work/beagleboard-
angstrom-linux-gnueabi/linux-omap-2.6.28-r27/git'
  OBJCOPY arch/arm/boot/zImage
  Kernel: arch/arm/boot/zImage is ready
  UIMAGE arch/arm/boot/uImage
/mnt/c/beagle/oe/tmp/staging/i686-linux/usr/bin/mkimage: Can't map
arch/arm/boot/uImage: No such device
make[1]: *** [arch/arm/boot/uImage] Error 1
make[1]: Leaving directory `/mnt/c/beagle/oe/tmp/work/beagleboard-
angstrom-linux-gnueabi/linux-omap-2.6.28-r27/git'
make: *** [uImage] Error 2
FATAL: oe_runmake failed

I've tried going into the tmp/work/... directory and compiling using
"make CROSS_COMPILE=arm-angstrom-linux-gnueabi- uImage", but still get
the same error.

On the other hand, I'm able to compile the kernel I got from
git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git
using the CodeSourcery toolchain without any problems.

Has anyone seen this error before? Anything I'm doing wrong? Does this
have anything to do with the initial warnings about the preferred
version of u-boot not being available?

Thanks,
Ravi

Hi Ravi,

you should post questions regarding oe to the oe mailing list [1]:
openembedded-devel@lists.openembedded.org

What you can try is to switch to the stable/2009 branch of oe [2],
x11-image must be buildable there.

Regards,
Matthieu.

[1] http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
[2] http://wiki.openembedded.net/index.php/Stable

Which is also what http://www.angstrom-distribution.org/building-angstrom tells people to do.

regards,

Koen

Matthieu, Koen:

Thanks very much. I was following the instructions at
http://elinux.org/BeagleBoardAndOpenEmbeddedGit. Will try the stable/
2009 version