Only mono output from Beagle Board

     We are using BeagleBoard for a VOIP application.We are setting up
audio call between BeagleBoard and a Desktop Phone(SJ phone) .We can
hear the audio output spoken at Desktop phone at beagle Board side.
But the audio is only mono.We are using ALSA driver.There is one ALSA
API to set the number of channels.We set the channels using the API
snd_pcm_hw_params_set_channels(playback_handle, hw_params_playback,2)
as 2.
But still we are able to hear only mono.
Is it some settings related issue in beagle board or do we need to
change the kernal configuration???
Can anybody give me some solution for this??

Smitha Rajan

Stereo is checked on every board using the process at Can you try that and report your results?

I have used the Ekiga softphone running on Beagle to talk to the SJ
phone running on my Windows laptop. The Ekiga softphone is very flaky
and crashes often. But if I initiate the call from the BB and call
the SJ phone, then it seems to work most of the time. If I initiate
the call on the SJ/Windows side, then the Ekiga phone rings. But
Ekiga crashes as soon as I click "Answer".

Best regards,

now i am booting from card.I tried to use arecord as per that link.Its
saying arecord command not found.

this link is working fine for getting stereo.But wen i run my
application it is showing only mono.:frowning:

I copied the arecord and aplay to mi its working fine


I am working on rev b7 beagle board.

using arecord and aplay, we are able to test the mic-in and speaker in beagle board.

Then, i ported linphone-3.1.0 to the beagle board.

Then i tested voice chat having between PC and linphone on beagle board.

the result is,

  1. able to hear the voice at beagle board whatever user speaks at PC.
  2. not able to hear the voice at PC whatever user speaks from beagle board.

Thus twl4030 codec driver full deplex.

when i debug linphone, stereo mode is 0 and channels set is 1.

the output of aplay and acrecord , strero mode is 1 and channels set is 2.

where to get the aplay and arecord code for beagle board.

what kind of problem this might be?

Thanks and Regards,