OpenEmbedded build error for meta-smartphone

I was following these step here to build images for beaglebone:

git clone git://
cd setup-scripts
MACHINE=beaglebone ./ config beaglebone

But always encounter the following HTTP request error for meta-

layer repository name: meta-smartphone
layer uri:
layer branch/revision: master/HEAD
Layer checkout missing at /home/user/xd/01_beaglebone/01_oe/setup-
scripts/sources/meta-smartphone, creating one
Initialized empty Git repository in /home/user/xd/01_beaglebone/01_oe/
error: Failed connect to; Operation now in
progress while accessing

fatal: HTTP request failed
/home/user/xd/01_beaglebone/01_oe/setup-scripts/scripts/layerman: line
16: cd: /home/user/xd/01_beaglebone/01_oe/setup-scripts/sources/meta-
smartphone: No such file or directory
/home/user/xd/01_beaglebone/01_oe/setup-scripts/scripts/layerman: line
32: cd: /home/user/xd/01_beaglebone/01_oe/setup-scripts/sources/meta-
smartphone: No such file or directory

Layers present in repository:
find: `/home/user/xd/01_beaglebone/01_oe/setup-scripts/sources/meta-
smartphone': No such file or directory

Can someone help me out ?


It seems come from your internet connection, I think.

I used to found problem seem to you.
At that time I changed my Network Adapter’s configuration (configuration in virtualbox) from NAT to Bridge Adapter.
So, try do it. Hope it help.

Sorat A.

Hi Sorat, Thanks for your suggestion.

But I was using a dial-up networking instead, under VMWare which is
running a lucid ubuntu on a Windows XP host machine.

Is there any "trick" that I need to do to the modem ? or the dial-up
setting ?

- Thomas

In my case, no need to do anything with modem or dial-up setting.