panda3D on beagleboard

Hi guys,

I'm trying to run the panda3D package to run some opengl applications.

My beagleboard is Rev. B5 running the ubuntu9.04 with kernel 2.6.29 as
guided in [1]
Of course, I installed the SGX driver according to the instruction in
[2] and managed its demos running successfully.

- When I brought the source package to the board and ran the
makefile(tried native compiling), the compilation stopped complaining
that it does not have 'bison'. So, I installed it.

- When I tried it again, the compilation stopped with 'out of memory' error.

1) I wonder if there is anybody tried this or even was successful.
2) I'm thinking of getting a Rev. C board which has 128MB more RAM
thank my Rev. B5 and try this again. Do you think this is worth to
try? Or is there any other think I might try with my current board?
3) If panda3D is not a proper solution to run on the beagleboard, is
there any suggestion?

Thank you for your time. :slight_smile:





Do you currently have a swap partition, it definitely won't be as fast
as the 256 memory version, but it might be enough to get it built.

(quick google guide, untested)


Hello, Robert,

Thank you for your comment. :slight_smile: You always are my first aid. :slight_smile:

No, I don’t have a swap partition now. First time I played with mojo project, I set up a swap. However, I decided not to use it because it would a) slow down the execution speed, b) the SD would wear out faster.
I even use ext2 filesystem for the rootfs instead of ext3. You probably remember that there once was a thread talking about the issue before in this mailing list.

I would try your advice… but I’m afraid it would take for eveeeeer to compile the package… :frowning:



2009/5/15 Robert Nelson <>


- When I tried it again, the compilation stopped with 'out of memory' error.

Try to run gcc with
--param ggc-min-expand=0 --param ggc-min-heapsize=16384

This worked fine for me with 128MB of RAM.