pip issues 5599

I have a base installation of bone-debian-10.3-iot-armhf-2020-04-06-4gb.img I have the sudo upgrade and update. I am try in to install PyQt5 with >> sudo pip3 install PyQt5

I get the following error.

WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip. Please see ImportError in system pip wrappers after an upgrade · Issue #5599 · pypa/pip · GitHub for advice on fixing the underlying issue. To avoid this problem you can invoke Python with ‘-m pip’ instead of running pip directly.

I have tried a few thing to resolve this but have not reached any progress
Any advice on this would be great.
I have all of this working on my desktop Ubuntu PC. Just stumped on the Beaglebone.


Did you try w/ apt yet? I think the command is sudo apt install python3-pyqt5 .


P.S. apt-cache search python3-pyqt5 will output many different libs. that are available. Also…instead of invoking pip3 directly, yes, you can use python3 -m pip install smbus2 or whatever lib. you are looking to install.

I tried the above using > python3 -m pip install pyqt5 and got the following result

debian@beaglebone:~$ python3 -m pip install pyqt5
Looking in indexes: Simple index, piwheels - Simple index
Collecting pyqt5
Using cached https://files.pythonhosted.org/packages/3b/27/fd81188a35f37be9b3b4c2db1654d9439d1418823916fe702ac3658c9c41/PyQt5-5.15.6.tar.gz
Installing build dependencies … done
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/usr/lib/python3.7/tokenize.py”, line 447, in open
buffer = _builtin_open(filename, ‘rb’)
FileNotFoundError: [Errno 2] No such file or directory: ‘/tmp/pip-install-mcfsiwpp/pyqt5/setup.py’


Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-install-mcfsiwpp/pyqt5/

still stumped.

Hello @Montuky ,

From the install page of PyQt5, Wheels are provide for 32- and 64-bit Windows, 64-bit macOS and 64-bit Linux. So, I think we are out of luck here w/ PyQt5 w/ installs from wheels or pip3 or python3 -m pip install.

I think this means only 32-bit Windows. I remember when it worked. I used to make Gaussian Distributions on a PyQt5 Window in Linux 32-bit armhf. Now, I think this is unavailable due to what the co. that PyQt is owned by currently has awarded to the world. Although depressing, it is reality.


P.S. I just read their PyQt6 ideas and they only provide 64-bit installs. Anyway, times…they be a changin' .

@Montuky ,

Have you found anything different from what I typed a week back? I could not, cannot, get the PyQt5 install working like I used to make it work.

I know they used to have a github.com page but I have not found it recently.

Also, if you find their github.com page again, install cmake, git clone the repo, and then mkdir a build dir, and then cmake … and/or cmake --build …


P.S. It is like they just up and are gone. Anyway, if you find anything different on your side of things, please keep this post alive.

No, nothing new. I got the same results as you from your last post. I really wished this worked. I started reusing the BBB to use specifically with a GUI interface using PyQt5.
I have started looking at some wxPython stuff to use instead.

Yes, will update if anything new is found .

1 Like