pip : problem confirming the ssl certificate

Dear all,

I have now installed pip using easy_install

root@beaglebone:~# pip --version
pip 1.3.1 from /usr/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg (python 2.7)

I am trying to use pip to install a new package that is not in the angstrom distrib.
but get this error :

Downloading/unpacking configobj
Could not fetch URL https://pypi.python.org/simple/configobj/: There was a problem confirming the ssl certificate: <urlopen error [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed>

My install is the latest (3.8.12) with

root@beaglebone:~# python -c “import ssl; print ssl.OPENSSL_VERSION”
OpenSSL 1.0.0j 10 May 2012

What can I do ?

Thanks

Jacques

Do you have the ca-certificates package installed?

It seems so :

root@beaglebone:~# opkg install ca-certificates
Package ca-certificates (20130119-r0.0) installed in root is up to date.

ssl certificate problem still not solved.

My configuration is brand new from the latest release.

root@beaglebone:~# cat /proc/version

Linux version 3.8.13 (koen@rrMBP) (gcc version 4.7.3 20130205 (prerelease) (Linaro GCC 4.7-2013.02-01) ) #1 SMP Mon May 13 08:43:47 CEST 2013

I have pip installed with easy_install

root@beaglebone:~# pip --version

pip 1.3.1 from /usr/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg (python 2.7)

I have ca-certificates

root@beaglebone:~# opkg install ca-certificates

Package ca-certificates (20130119-r0.0) installed in root is up to date.

And still I have problems with ssl certificates

root@beaglebone:~# pip install configobj

Downloading/unpacking configobj

Could not fetch URL https://pypi.python.org/simple/configobj/: There was a problem confirming the ssl certificate: <urlopen error [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed>

Thanks for any help on this matter.

Jacques

Could not fetch URL https://pypi.python.org/simple/configobj/: There was a problem confirming the ssl certificate: <urlopen error [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed>

A google search on the error msg took me to:
http://stackoverflow.com/questions/10667960/python-requests-throwing-up-sslerror
whiere the thread seems to imply that it is a result of encountering an “untrusted” cert. It suggests an “ignore” option in code. May want to try that…

/venkat

Thanks for the suggestion. I did not try it, as I am not that expert, but on

https://github.com/pypa/pip/issues/829

They have documented the same problem on various systems with pip 1.3.1

The suggestion was to downgrade pip with

easy_install pip==1.2.1
This fixed also the problem for me on the BBB. 
Jacques

The problem is the internal clock in the BBB.

If you run

ntpdate -b -s -u pool.ntp.org

you won’t get the ssl error. However, you will have to do this every time you want to use pip.

This solves the problem, Thanks!!

Thanks man, this worked perfectly for me

I followed the instruction from http://eric.lubow.org/2011/security/fixing-centos-root-certificate-authority-issues/ and solved the problem.

after a few years this worked for me on a beagleboneblack running debian 9.3, though ntp is blocked on our network, htpdate does the job ,
thanks