Plugging in USB Flash Drive Locks up all other USB Devices

I have the latest Angstrom demo image (Jan-4-2009) running on my
BBoard. Recently when I plug in my USB Flash Drive to transfer files,
all other USB devices lock up (Keyboard, Mouse). This just started

Does anyone have any idea as to why this would occur?

I do not have a USB Ethernet device to connect to the board and am
still trying to get the Belkin Wireless G suggested as working with
BeagleBoard to work. USB Flash drive is my only other option other
than shut down and putting files onto the SD card.


I've had similar problems -- I think my problem is my +5V supply
glitching when I plug in the Flash drive. I'm powering both the
BeagleBoard and my USB hub from the same +5V supply, so any +5V
glitching on the USB hub can confuse the BeagleBoard's USB controller.

You might try plugging in the USB Flash drive before booting Ångström,
rather than plugging it into a running system.

I don't know what standard (if any) USB hubs must follow for hot-
swapping devices. I would think that a good USB hub should have a hot-
swap controller on each port. My $5 hub doesn't.


To get your Belkin Wireless adapter working, you may want to check this link. I tried and it worked for me.


Are you using a powered usb hub or just the power coming off the beagle
board? The beagleboard can only source 100 mA.


I have the same issue with my WD external USB HDD. I have only tried
pluggin it in when the board is powered up. When I get a chance I will
give it a go starting with the board powered down. Oh an I am using a
powered USB Hub.