PocketBeagle and apt-get

I’m new to BeagleBoards and have a Fedora Linux background. Getting a PocketBeagle running Buster Debian (bone-debian-10.3-iot-armhf-2020-04-06-4gb.img) while connected to Fedora Core 34 Linux PC has been a challenge. From previous posts here I learned:

You first need “Internet Connection sharing” setup on your PC (laptop, whatever). Windows and Apple seem to have a GUI for handling it.
On FC34, you need to enable IP forwarding; “sudo sysctl net.ipv4.ip_forward=1”, then setup iptables; “sudo iptables --table nat --append POSTROUTING --out-interface <your_Inet_Iface> -j MASQUERADE” and “sudo iptables --append FORWARD --in-interface <tethered_Iface> -j ACCEPT”. Then “sudo route add default gw” on the PBBB, along with “sudo echo nameserver >> /etc/resolv.conf”.
That works for the most part. I had to unlink /etc/resolve.conf from /run/connman/resolv.conf to get the last command to work. The connman Man Page said that it blacklists usb* connections, meaning it doesn’t handle them. Not sure what connman is but I figured its the equivalent to NetworkManager in FC34.
Now pings to deb.debian.org and repos.rcn-ee.com work. But I get an error from apt-get “Could not connect to deb.debian.org:80 ( - connect (113: No route to host)”. Obviously wrong, I can ping it. So I tried a work around DNS. Incidentally, there is no “nslookup” or “dig” in this Debian image. Any alternatives?
I wrote the two repo IPs to /etc/hosts and modified /etc/nsswitch to use “files dns”. Again, I can ping them, by name or number but apt-get still complains there is no route to host. What am I missing? Is this an iptables issue on the PC, not forwarding connections to the web site?
Any hints would be greatly appreciated! Thanks in advance.


Sometimes there are network issues to the debian site, perhaps during maintenance and such. Have you tried this again?

Also, on the FC34 system, is it connected via hardwire ethernet to the router or are you using a Wireless connection. If it is wireless, you might have to route that as well.

On the PB, you might want to try this:

If you haven’t yet, have a look at the following:

Also, there might be something you can be pick up from the following thread on the old forum.

You’ll have to do the translation from Debian to FC34 though.


Thank you for the excellent suggestions. I will have a look. I was able to work around the problem by setting up a local repository and thus get a JVM installed. Ironic that the JVM install went without a hitch. I was figuring that would have been the biggest effort in my PB project.