Pocketbeagle internet connection stopped

So I did all the steps to have internet via usb from windows 10:
1- I did the sudo route add default gw
2- I enabled internet sharing within my network and manually set the ip for the usb connection.
3-I added nameserver nameserver to /etc/resolv.conf
4- I also added files to root and /etc/init.d so I wouldn’t have to do this at every reboot
5- I also did the necessary chmod and symbolic links commands

So after this I reboot and I had internet, and to make sure, even reboot my note and pocket again, and still had internet, after a few days, the internet is one and all the files and setup are still the same.Does anyone have an idea of what’s going on?

my first reaction is to blame Windows, but to make sure

from a terminal on the beagle

can you ping ?
If not, on windows check to make sure the interface on it is actually

check the default route is actually set.

depending on what is installed, one of the following should work

route -n
ip route

if it is, can you ping from the beagle.
If not your issue is with windows not routing traffic.

if you can then the internet should be accessible

try doing a ping google.com from the beagle.
If that fails then the issue is with DNS.

If the beagle is using systemd-resolve you can check DNS servers by doing

systemd-resolve --status | grep "DNS Server"

or double check resolv.conf. Depending on the networking, you probably shouldn’t be editing this file as it is often dynamically generated.

1 Like

Thank you answering.

can you ping

Yes, I can.

check the default route is actually set

I don’t know how to check that but I am going to show the output from the two commands:

route -n

ip route

try doing a ping google.com from the beagle

it returns this :

ping: google.com: Temporary failure in name resolution

systemd-resolve --status | grep “DNS Server”

This give me this :

Failed to get global data: Unit dbus-org.freedesktop.resolve1.service not found.

double check resolv.conf
In resolv.conf there are these two lines

Ok DNS is not working.

Can you ping and ?

Sorry it took me a while to answer. Nothing happens and if I use ctrl+c it outputs 100% packet loss
for both of them.They can transmit but not receive.

Hi, so I disabled internet sharing , rebooted both my machine and pocket, then enabled it, did the ipv4 configuration for the usb connection, rebooted the pocket again and now it works. I don’t if it helps much figuring out the DNS problem. I didn’t modify anything that I already had ready in pocket, only the things I had to do on windows side.