Possible opkg update/upgrade issues with 05/08/13 image


I was able to install the BBB-eMMC-flasher-2013.05.08.img.xz image fine via an uSD card. However, in an attempt to fetch some latest python packages, when I ran the:

opkg update
opkg upgrade

while it was running, At the end of the process, I noticed the following error summary:

Collected errors:

  • opkg_finalize_intercepts: Failed to open dir

/tmp/opkg-EJegmu/opkg-intercept-AmeBYC: No such file or directory.

  • rm_r: Failed to open dir /tmp/opkg-EJegmu/opkg-intercept-AmeBYC:

No such file or directory.


'am wondering if it is an error with the installation (via setuptools ?) of some python module it fetched. I have seen errors like this in past, with race conditions during setuptools usage. setuptools (and possibly via distutils) uses /tmp/ to unravel sources/eggs during the install process and the error msg above refers to /tmp/. Hence the presumption. There are no other clues.

I could no longer boot the bbb in this errored out install. None of the user LEDs would come on despite power being ON. Only recurse was to reflash the pristine 05/08/13 image, and then things are fine

So it appears, the above upgrade method is still not fully functional.


I had the same issue with a upgrade seems its still broken

the newer image is mostly up to date and really does not need the whole upgrade

but it would still be nice to not have to reflash the latest image after an upgrade to fix the issue

I just successfully completed an opkg update+upgrade from the 2013.05.08 image.

Here is what I did, I don’t know how much my config/setup affected the outcome:

  1. I dont have it hooked up to my workstation. Instead, I have it connected via ethernet+dhcp and I ssh into it from any machine I happen to be on.
  2. Halfway through the upgrade, I got a string of errors about not being able to download packages. It turned out to be caused by a DNS lookups failing. I manually overwrote /etc/resolv.conf with what I usually use. Then I restarted the update+upgrade and it seemed to work.

I still get an error at the very end complaining about a name clash for /usr/bin/stream … apparently lmbench supplies /usr/bin/stream, but the new version of ImageMagick wants to put a file there. I havent looked into it to try and resolve it.

I just picked up a chromium update and rebooted and all looks good :slight_smile:


  • Vijay

I ran into problems today trying to do opkg update/opkg upgrade.

I was at 3.8.11 r23 something or other. I believe it was the 05.06 updates and I was planning to pull down 05.08 by that method.

I finally figured out why everything went awry. The package repository got updated with a new build between 11h and 18h UTC today. I had to restart multiple times.

I have consistently had the name server issues when doing opkg upgrade. I have tried the following in an attempt to permanently address the issue:


where is equivalent to the following:


Take a look here for a better explanation:


In theory this should ensure that your nameserver settings are retained but I haven’t done enough upgrades since I made the modification to feel confident that it has done the trick.

Anyway, I was getting a very messy mix of old and new packages and multiple errors because of the mixup combined with the inconvenient tendency for connman to ‘forget’ the nameserver setting it received from my DHCP server while doing opkg upgrade.

I still haven’t fully fixed it yet. I’m trying to avoid flashing a new image because I don’t currently have a spare SD card that I can use.

Hi Venkat,

I’ve got the same problem after upgrading BBB. Did you able to fix the problem finally, pls?