Problems for flashing BeagleBone Black

Hi everyone, I’m trying to flash my beaglebone black. It has installed Debian, since it’s not mine, but I need to reset it to Angstrom to work with it. I’m following the guide to do it, but it says it’s about 30-45 minutes, but it never gets the four leds on. Only d3 and d4 are flashing and nothing happens.

I want to know what can be the issue, I’m powering it by the 5v pin not by usb, and I’m using latest update of angstrom in the official website from Beagelbone. I’m sure it is properly powered, since it looks is the most common trouble, and I’m using a 4gb SD card.

Thanks in advance

I think the only way you’re truly going to know whats going on is get access to the console. One way to do this would be by buying a serial debug cable as described here:

But perhaps if you give us the exact steps you’ve taken to try and achieve what you want. Maybe someone can spot what is going wrong.

I finally fixed it. I don’t what happened, I downloaded another version of Angstorm and finally worked. Thanks for your help anyway

It would be really helpful to others who stumble on to this thread to give the links to the image that worked as well as the one that didn’t!

I just flashed and rebooted my old Rev A5A BBB using this image:

This apparently “newer” one didn’t work for me:


For me, this worked