Problems with beagle as samba/sftp-server with attached usb mass storage

Hi all!

I have a problem with my beagle running BeagleBoardDebian or
BeagleBoardHandheldsMojo. I have a USB-hub with a USB-Ethernet-dongle
(noticed as MOSCHIP 7830/7730) a keyboard and a USB mass storage
device connected. Everythings so far works fine, but if I read files
via samba/sftp from the USB mass storage via another computer, my
beagle "crashes" after a few seconds.

Copying from the USB mass storage to the sdhc-card works as well as
copying files from the sdhc-card via samba/sftp to another computer.

I have tried each of the following precompiled kernels:

Is there perhaps a problem with my usb-ethernet adapter? Should I go
out and buy a Linksys USB200M as recommended on

Or is there a problem with the USB-multiplexing in any kernel driver?
I even tried another USB-hub.

I would be very glad for every peace of help, because I really need
this to work for my beagle.


I'm running the same ethernet hardware as you on my build beagle, and
i believe i'm seeing the same issue. I'm not sure of the root cause

Bus 001 Device 004: ID 1058:0901 Western Digital Technologies, Inc.
MyBook External HDD
Bus 001 Device 003: ID 9710:7830 MosChip Semiconductor MCS7830 Ethernet
Bus 001 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub /
D-Link DUB-H4 USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Under high usb loads, such as moving a file directly from the USB
Harddrive, thru the USB ethernet to an external network device, the
USB will 'hang' for a moment and seem to reset. In my case, the
beagle hard locks, since i'm usually running one of the deb based
chroots on my USB Harddrive and a whole bunch of nasty things happen.
For the moment, i temporally move files from USB Harddrive to the mmc
card, before uploading them.