problems with static ip address on eth0

I downloaded the newest image (bone-debian-8.4-lxqt-4gb-armhf-2016-05-13-4gb) and I am now trying to configure the eth0 to be able to use the BBB on our network.
I can connect to it over USB link.
I changed the /etc/network/interfaces file to the content shown below, but after reboot the BBB gets address (an address assigned after failed DHCP assignment attempt?)
After some searching, I have the impression that this is because the usb0 link uses dhcp, and the BBB is also using this on eth0, although I tell it to use ‘static’ in the interfaces file.
If I restart the eth0 link using ‘ifdown eth0’ and ‘ifup eth0’ then it does get the right ip address, and I can ssh to it over the eth0 interface. But this is not really a good solution, and I have the impression that some other network settings, (dns, …) are still misconfigured.

I tried deleting the usb0 link from /etc/interfaces, and disabling the /opt/scripts/boot/ script, but that didn’t help either.
Is there any way I can force it to use a static IP address on eth0?

Thanks for any help


root@beaglebone:/etc/network# cat interfaces

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

auto eth0
iface eth0 inet static

Example to keep MAC address between reboots

#hwaddress ether DE:AD:BE:EF:CA:FE

The secondary network interface

#auto eth1
#iface eth1 inet dhcp

WiFi use: → connmanctl

Ethernet/RNDIS gadget (g_ether)

Used by: /opt/scripts/boot/

iface usb0 inet static

Have you tried booting with the USB cable not plugged into your computer?

I’ve never tried using both the USB gadget and wired Ethernet at the same time.

When I want a static IP on the local network I usually find it easier to go to the router’s admin page and set a static IP based on the board’s MAC address. Then I don’t have to keep editing the config files on the Bone, or Pi etc.

The magic for static eth is:

sudo connmanctl config <service> --ipv4 manual <ip_addr> <netmask>
<gateway> --nameservers <dns_server>


debian@beaglebone:~$ connmanctl services
*AO Wired ethernet_74daea0a4b52_cable

sudo connmanctl config ethernet_74daea0a4b52_cable --ipv4
manual --nameservers


Hi, Have you solve the problem? I have the same problem as you, could you please advise?

You need to configure connman, not /etc/network/interfaces:!topic/beagleboard/yfNwIk_dWlg