Production tooling (MSPGCC)

I am experimenting with using a beaglebone for some production tooling. I would like to use desktop for a nice fancy GUI to show screening results and I also need to have the beaglebone program an MSP430 processor using a TI FET tool.

Well that’s what I want, getting it is another thing. I have a beaglebone and a 7" ldc from circuitco (got it awhile ago) and I’m trying to get a desktop installed. I could go with the Angstrom distribution that comes stock but I’ve tried installing a ubuntu image then LXDE but LXDE hangs on the login screen. I then tried installing ubuntu desktop and got the same results so the stock Angstrom is looking much better now.

I can work with the angstrom distribution but I need a little help in getting the MSPGCC tool chain running on it. I’m strating from near zero, it’s been a long time since I’ve done any linux stuff. Can someone give me a roadmap on what I have to do?

The official debian image posted here:

should not lock up at the login screen with your lcd.

Then just "sudo apt-get install gcc-msp430"


If that is the same toolchain thats been around for years, mspdebug may have issues on any Linux. Redhat has supposedly been tasked by TI to build an up to date toolchain that I hear was working( and had a decently working mspdebug ).

Mspdebug is in a separate package. The trick with getting it to work with the FET under Linux has been the need to build TI’s MSP library. However, someone has done the footwork and pulled together all the patches and fixes required and checked everything into github here. Last I tried a few weeks ago it built and worked with the latest mspdebug package just fine.