PRUCookbook Comments

Mark A. Yoder <mark.a.yoder@gmail.com>

Fri, Aug 17, 7:58 AM

to BeagleBoard

The PRU cookbook is nearing completion (more accurately, I’m running out of summer).

Here’s a link https://markayoder.github.io/PRUCookbook/

I’m happy for any feedback you can give me.

–Mark

Great format, I really like it online.
To test it I choose a BeagleBone Black Wireless (as it turns out it was spare) and it already had a version 4.9 onit and upgraded it to
Linux beaglebone 4.14.69-ti-r75 #1 SMP PREEMPT Thu Sep 13 23:34:50 UTC 2018 armv7l GNU/Linux

Initially I followed instruction using USB, but then changed to wireless. Following is suggestions/observations

https://markayoder.github.io/PRUCookbook/02start/start.html

1.3. Flashing a Micro SD Card

Solution

Once the SD is flashed, insert it in the Beagle and power it up.

To permanently copy the image to the Beagle, copy it to Beagle flash.

[Reference to flashing beaglebone but post 4.4]

sudo nano \boot\uEnv.txt - remove from #cmdline

##enable BBB: eMMC Flasher:

cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

toexit: save

sudo powerdown

Then press power button.

The device upgrades, and then powers down.

Remove uSD before pressing power switch.

1.4 Cloud9 IDE

for windows http://192.168.7.2:3000, for other computers see…

1.5 Getting Example Code

Setup for internet.

Ethernet - connected automatically

USB -

needs to be connected to the wireless

<comment 4.14.69-ti-r75 using USB>

The following is repeated a number of times in different place:

git clone https://github.com/MarkAYoder/PRUCookbook.git

Cloning into ‘PRUCookbook’…

fatal: unable to access ‘https://github.com/MarkAYoder/PRUCookbook.git/’: Could not resolve host: github.com

when setup for WiFi - it worked.

1.6. Blinking an LED

Running Code worked for me

https://markayoder.github.io/PRUCookbook/03details/details.html

1.2 Compiling and Running

debian@beaglebone:/var/lib/cloud9/git/PRUCookbook/docs/06io/code$ source gpio_setup.sh

PRUN=0

TARGET=gpio1

Wireless Not Found

$ cat /proc/device-tree/model

TI AM335x BeagleBone Black Wireless

workaround - make all defaults of pins P9_11

1.8 & 1.9 not checked.

Dude, you’re a genius. You help me a lot !!

Thank you very much!!!

I’m glad you like it. Let me know if you have any questions for suggestions for improvement.

–Mark

Yes, I made some adjustments in the Makefile to simplify the addressing of PRUs, see if it is useful:

`

Lookup PRU by address

ifeq ($(PRUN),0)
PRU_ADDR=4a334000
endif
ifeq ($(PRUN),1)
PRU_ADDR=4a338000
endif

PRU_DIR=/sys/class/remoteproc/remoteproc$(PRUN)

all: stop install start

stop:
@echo “- Stopping PRU $(PRUN)”
@echo stop | sudo tee $(PRU_DIR)/state || echo Cannot stop $(PRUN)

start:
@echo “- Starting PRU $(PRUN)”
@echo start | sudo tee $(PRU_DIR)/state

`

Yes I need help,

I am using BBW and since last two days it is not getting detected in desktop computer what will be the possible cause of the problem,
It is booting properly that I can confirm by seeing led blinking,
Please help me.

You could download a default image and write to an sd card so you can confirm if it is a software or hardware problem so you know if your board is damaged.

I have write new image to BBW but there isn’t any change.