[Q] Enabling ADC without Device Tree file

Can anyone let me know what register should I use for this?

I just tried to read following register value


where REVISION ( of TRM) register is. But without

slotting BB_ADC to capemgr, what I’ve got is following error:

Unhandled fault: external abort on non-linefetch (0x1018) at 0xb6f11000

This kind of error, I have experienced with GPIO3 register and I found that

turning on clock using CM_PER_GPIO3_CLKCTRL( of TRM)


However I cannot figure out what register should I turn on, I’ve tried with

CM_WKUP_ADC_TSC_CLKCTRL but it does not solve my problem.

Thanks in advance.

Sorry for reposting, I have not assigned board before.

Though no one is interested in this subject, anyway I found one solution;

Set CM_WKUP_ADC_TSC_CLKCTRL in privileged mode, which I mean in the kernel module.
I cannot figure out why this register is not modified in mmaped /dev/mem, however, in kernel
module or kernel space, I can modify this register as |= 0x2.

Can anyone let me know why I encountered this problem? As far as I know only GPIO control
registers need privileged mode to modify their values…