Qt embedded integration with OpenGL ES problem Options


  we did let OpenGL ES work on beagleboard, but still with some
problem needed to be fixed. we modified hellogl_es example code. we
note that: with full screen, the example can work, but with a window (
not fullscreen), it twinkled , rendered some color bars on to screen.

   for more detail, please refer to:

   I found that, there is a openembedded recipes under development
related with opengles/qte. I don't tried that, maybe it's still on

  if you compiled you hellogl_es demo, but not work properly, you
should debug it with you own qte opengl es code, such as how to render
a simple triangle on screen to see if it can be draw on screen. after
that, you should let you triangle rotate to see if it work as you

   we debug step by step like that, and finally found something. the
Qte opengl es demo can be modified work on fullscreen. we don't know
what to be fixed, maybe some one can point out this.

  I hope this helps. if you find more info about QTE/OPENGL ES, please
update this thread to share with more people.


I have gotten OpenGL ES 1.1 and 2.0 running on Omap3. However, still the apps using QLWidget like 2dpainting does not work. Qt guys are looking into this issue and hopefully this will get solved in near future.

But, hellogl_es demo works fine on 1.1 and 2.0.

For this,

I am using Qt source: http://qt.gitorious.org/+ti-sys-app-omap-team/qt/ti-sys-app-omap-team-clone/commits/omap3-support
Ø git clone git://gitorious.org/+ti-sys-app-omap-team/qt/ti-sys-app-omap-team-clone.git
Ø git checkout 15fa3b0fb140af9a1ae5e51a95fe3cf97cfa69eb

For building Qt: I used the following options for configuring Qt

./configure -prefix /opt/qt-embedded/ -embedded arm -little-endian -fast -D QT_NO_QWS_CURSOR -D QT_QWS_CLIENTBLIT -depths 16,24,32 -xplatform qws/linux-omap3-g++ -arch arm -no-xinerama -no-xkb -opengl es2 -plugin-gfx-powervr -qt-mouse-pc -no-openssl -no-cups -no-phonon -no-largefile -qt-mouse-pc
-plugin-mouse-pc -qt-mouse-tslib -plugin-mouse-tslib

After everything is built and installed on the filesystem, I used the following environment variable:

export TSLIB_FBDEVICE=/dev/fb0
export TSLIB_TSDEVICE=/dev/input/touchscreen0
export TSLIB_CONFFILE=/etc/ts.conf
export QWS_DISPLAY="powervr"
export QWS_MOUSE_PROTO=tslib
export LD_LIBRARY_PATH=/lib:/usr/lib:/usr/X11R6_SGX/lib:/usr/local/lib:/opt/qt-x11/lib
export DISPLAY=localhost:0.0

Please run the app in examples/opengl/hellogl_es:
./hellogl_es -qws

Hope this will help.

Varun Shah

Please use the mail below along with instructions from Pratheesh found in thread: http://groups.google.com/group/beagleboard/browse_thread/thread/06354a2c618365d6

For opengles 1.1, you will need to comment the lines as mentioned in step 2 by Pratheesh in the thread above. For opengles 2.0, you do not need to comment the lines.

Varun Shah

First in need to do "make all" in the Graphic-SDK to build the
libraries right?
then i get:

make[1]: arm-none-linux-gnueabi-gcc: Command not found
make[1]: *** [../LinuxOMAP3/ReleaseRaw/OGLESChameleonMan.o] Fehler 127
make[1]: Verlasse Verzeichnis '/home/michi/
make: *** [/home/michi/OMAP35x_Graphics_SDK_3_00_00_06/GFX_Linux_SDK/
OGLES/SDKPackage/Demos/ChameleonMan/OGLES/Build/LinuxGeneric] Fehler 2

I want to use the OE Toolchain in: /home/michi/oe/tmp/cross/armv7a
So i export the toolchain into PATH but the error still remains!
How do i change the arm-none-linux-gnueabi-gcc to --> arm-angstrom-
linux-gnueabi ?

Please edit the ~/OMAP35x_Graphics_SDK_3_00_00_xx/Rules.make to set your angstrom toolchain.

Look for "set toolchain path" under "FIELDS MODIFIABLE BY THE USER" in Rules.make.


Varun, Where did you the opengl es library from?
Can you share that with me please?



The OpenGL ES library is part of the OMAP35x_Graphics_SDK released by TI on regular basis. We have recently announced .09 release for the same. Please find the announcement mail from Pratheesh along with the links for downloading attached below.

I hope this will help.


Thanks Varun. I have installed the OMAP35x_Graphics_SDK.

But it looks like it needs kernel 2.6.29.

I am having omap zoom 34xx II and omap3 evm and cannot find 2.6.29
kernel (no config in kernel source) for my boards. Can I install the
opengl libraries to my device having 2.6.28 or 2.6.22 kernel? (how



You can use 2.6.28. Just need to rebuild the kernel modules for graphics. Please follow the getting started guide: http://www.tiexpressdsp.com/index.php/OMAP35x_Graphics_SDK_Getting_Started_Guide

Regarding getting the 2.6.29 PSP releases of kernel for EVM, You need to go on the website of TI as mentioned below by Pratheesh and get it from dvsdk link.

The new release of Qt Embedded 4.6 technical preview works great with the EVM. Yet to try on beagle board.


The 2.6.29 PSP release link is not working, can you post it again

I get a "segmentation fault" when I run the demo opengl examples.

The 2.6.29 PSP release link is not working, can you post it again

I get a "segmentation fault" when I run the demo opengl examples.