Qt embedded on a Debian Image

Hello all!

Has anyone been able to get a Qt embedded setup working on a Debian IoT image?

From what I have found, Qt5 no longer has it’s own windowing system so it would have to be a Qt4 setup in order to have the -qws option work.

I have been able to compile Qt4 locally on a BeagleBone Black (which took forever…) and can get the video to work on a Chipsee 4.3" LCD cape but I can’t get the resistive touch screen to work.

Ideally, the setup should be cross-compiled so that development and debugging could be done on a fast host system. I have tried to cross-compile Qt4 on various Debian VM’s I have setup but can’t get any of them to successfully compile the library.

The real annoying thing is, if you do a google search to find any information on this there is a ton of outdated info that just doesn’t work.

If anyone has a system that works and can provide the information on how to replicate it I would appreciate the help!


Does X11 or wayland work with that LCD? I'd expect the lxqt images to
ship a working version of Qt.

I think Qt just uses the standard input layer. What shows up if you run
the following?

$ tail -n 1 /sys/class/input/*/name

I gave up on the 4.3" LCD. It had to many issues (and the screen resolution
is not large enough for what I need). I’m now trying a 7" screen, specifically
the 4DCAPE-70T.

That screen works great with the latest Debian image:

$ cat /etc/dogtag
BeagleBoard.org Debian Image 2018-01-01

The board boots to the LXQt desktop and after calibration the touch screen
works fine.

I’m still having issues getting a Qt app to work. I tried Qt5 first with this simple
test code:


int main(int argc, char *argv[]) {
QApplication app(argc, argv);
return app.exec();

With Qt5, when I try to run the test app I get:

libEGL warning: DRI3: Screen seems not DRI3 capable
libEGL warning: DRI2: failed to authenticate

So I then tried Qt4. With Qt4 the test app doesn’t do anything. It just hangs
until I kill it.

I’m not sure where to go from here. Even if I get it working I still need to
figure out how to get Qt to work from the console with no X server installed.

Any help would be appreciated.