QT/X11 and OpenGL/ES on Angstrom


I’m trying to run QT/X11 on Beaglebard-xM with GLES/SGX support in Angstron 2012.12. I’ve tried thousands of tutorials on the internet and none worked.

I’ve tried install qt4-x11-free via opkg but it seems that it does not have support for SGX/GLES. I know because I stopped pvr drivers and the hellogl example started. Also, I’ve searched the libraries linked and none links to libGLES2.so or libGLES_CM.so.

I’ve tried to download QT 4.8.1 and cross compile with “angstrom-eglibc-x86_64-armv7a-vfp-neon-v2012.12-toolchain.gz” toolchain (downloaded here: http://www.angstrom-distribution.org/toolchains/ ) and only the non-GL examples worked. All the OpenGLES examples (hellogl_es[2] and textures) crashes with segmentation fault in the beginning.

I found in the code of the examples that the segmentation fault happens in the time that a QGLWidget is added in another layout widget (more precisely, in QGridLayout->addWidget method).

The compile parameters that I used:

./configure -prefix /media/develop/qt-target/ -opensource -confirm-license -arch arm -platform linux-g+±64 -xplatform linux-omap3-g++ -opengl es1 -no-mmx -no-3dnow -no-sse -no-sse2 -no-glib -no-cups -no-largefile -no-accessibility -no-openssl -no-gtkstyle -qt-mouse-pc -qt-mouse-linuxtp -qt-mouse-linuxinput -plugin-mouse-linuxtp -plugin-mouse-pc -fast

The qmake.conf of linux-omap3-g++ mkspec attached to this e-mail.

So… I have two questions:

  1. First of all, the QT/X11 works with GLES/SGX on BeagleBoard-xM? :). Most tutorials that I’ve found only talks about QT Embedded (which own QWS server and no X11 support, I am right?).

  2. If it works, someone can point me an updated tutorial for dummies to try or point me which I am doing wrong?


qmake.conf (2.22 KB)

+1 - I can run my qt program, but get no graphics.

I also want to know , when powervr will have wayland support ?