RCN kernel cpu-freq limit


I’m using the v3.8.x branch from RCN with a BBB clone based on am3352 with 800MHz factory rate. I can see that under heavy load the frequency goes up to 1GHz while it should be limited to 800MHz. Can anybody suggest a way to limit the frequency in the kernel?

I did some testing and setting the cpu frequency with the below command does limit it. Using sysfsutils and editing /etc/sysfs.conf to include these lines:

devices/system/cpu/cpu0/cpufreq/scaling_governor = ondemand

devices/system/cpu/cpu0/cpufreq/scaling_max_freq = 600000

sets the frequency at bootup. However the cpu still runs at 1GHz for a few seconds before these settings take effect, so I think we need a kernel change to fix this

Remove this line:



Robert, thanks!
Is there a way to detect the cpu frequency rate in kernel? Changing sources for different boards is not a good idea

Well the opp framework to detect these settings still isn't in
mainline. So we have to hard-code the frequency values in the dts

you could decompile the dtb file, remove that line and rebuild it, then reboot..