RE: [beagleboard] Configure CAN0 with buildroot

So here's the results of from both beagles. The rev 141 doesn't see the cape_CBB_Serial-r01 from Logic Supply as shown in the photo. For convenience I've also included the side by side compare of the two files.

Not sure why this install doesn't see the cape.



Oh fun, 2018 wth 2015 causing issues..

how set in stone are your for "2018-10-07" Release?


If you want to keep: "2018-10-07" here's what i would do:

#Good bye 2015 bootloader:

sudo apt update
sudo apt install bb-u-boot-am335x-evm
cd /opt/u-boot/bb-u-boot-am335x-evm/
sudo ./

#Latest v4.14.x-ti:

cd /opt/scripts/tools/
sudo ./

# and reboot..

now run:

sudo /opt/scripts/tools/

We should see a more friendly setup. :wink:


Hi Robert,
Not that set in stone really. Just that the last time I did one of those "you must upgrade to get support" I ended up buying a new edition of Derek Molloy's book because the $SLOTs stuff vanished which also made 5 other books I have on the Beagle pointless for the most part.

Between editions and versions my 4DCape LCD display also no longer worked so it's in the box of useless LCD displays along with the Manga 1 (never worked right) and Manga2.

How much of the step by step instructions in Derke Molloy's (c) 2019 2nd edition are voided and how will I know what is supposed to work and not.

I've done the following.
cd /opt/scripts/tools/
sudo ./
# and reboot..
now run:
sudo /opt/scripts/tools/


Does USB work after 30-45 seconds? If so, still trying to debug that…

I moved the MicroSD card over to the other Beagle. Booted and USB mouse and keyboard (Logitech wireless) work. The Logitech wireless was not discovered on the other Beagle.

I think it may be sick.

Last login: Fri May 14 18:11:06 2021 from

debian@beaglebone:~$ sudo /opt/scripts/tools/

[sudo] password for debian:




dogtag:[ Debian Image 2018-10-07]

bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot SPL 2019.04-g10968f0 (Feb 19 2021 - 21:40:51 +0000)]:[location: dd MBR]

bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2019.04-g10968f0]:[location: dd MBR]

bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot SPL 2019.04-00002-gbb4af0f50f (Jul 08 2019 - 11:44:39 -0500)]:[location: dd MBR]

bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2019.04-00002-gbb4af0f50f]:[location: dd MBR]

UBOOT: Booted Device-Tree:[am335x-boneblack-uboot-univ.dts]

UBOOT: Loaded Overlay:[AM335X-PRU-RPROC-4-14-TI-00A0]

UBOOT: Loaded Overlay:[BB-ADC-00A0]

UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0]

UBOOT: Loaded Overlay:[BB-HDMI-TDA998x-00A0]



/boot/uEnv.txt Settings:




pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]








groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai]

cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 quiet]

dmesg | grep remote

[ 1.108680] remoteproc remoteproc0: wkup_m3 is available

[ 1.453877] remoteproc remoteproc0: powering up wkup_m3

[ 1.453993] remoteproc remoteproc0: Booting fw image am335x-pm-firmware.elf, size 217148

[ 1.458014] remoteproc remoteproc0: remote processor wkup_m3 is now up

[ 165.380047] remoteproc remoteproc1: is available

[ 165.395267] remoteproc remoteproc2: is available

dmesg | grep pru

[ 163.347677] pruss 4a300000.pruss: creating PRU cores and other child platform devices

[ 165.380047] remoteproc remoteproc1: is available

[ 165.380228] pru-rproc PRU rproc node /ocp/pruss_soc_bus@4a326004/pruss@0/pru@34000 probed successfully

[ 165.395267] remoteproc remoteproc2: is available

[ 165.395389] pru-rproc PRU rproc node /ocp/pruss_soc_bus@4a326004/pruss@0/pru@38000 probed successfully

dmesg | grep pinctrl-single

[ 0.796710] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568

dmesg | grep gpio-of-helper

[ 0.809442] gpio-of-helper ocp:cape-universal: ready


Bus 001 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver

Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



I then created an sd card with this


Login prompt on screen with USB keyboard functioning.

This is without the CAN Cape. I’ve attached the serial port terminal log.

Next I’ll shut it down and put the cape back.

From the descriptions on I can’t figure out what the latest graphical desktop image is for the BBB.



ConsoleBootLog.txt (4.27 KB)

There really isn't an official lxqt release, it just was too un-useful: