RE: Trying to Make My Terminal State What I Type, for Instance "ls," When I am Using vncserver!


I have an issue. I wanted to run some tkinter ideas on my BBBW but when I get to vncserver as my command, I run into issues w/ my terminal on the VNC Viewer software.

I do not know which software relation I can call “closer-to-home” here. I am downloading LXDE right now and will be testing w/ this enormous amount of software to test things out.

Until then…

Here is the issue:

I type ls and I receive 'b back which shows on the terminal while on the VNC Viewer. I have tried other ideas:

  1. LXDE and I can see why people have strayed from it. It is complicated and not well established for some reason (any longer).
  2. I tried to use different viewers. No go.
    If you are having this issue, would like to work on it, or know what I can do to get out of the odd text issue, please let me know.


P.S. Here is ls on my screen when I type it:

I had the same issue with the default terminal window. I installed xfce terminal and it works fine for me. Below is the link that contains instructions. Follow step 1 to install xfce terminal.

Hello Krish,

Seth here. I am downloading the packages now. They are currently installing. I thought I would only install so many but that recommended installs/packages were many.

Anyway…thank you for your support. I will return service once the packages install and I test it out.



I got it. You were right. That window Manager, XFCE, works well. It took a lot of extra packages to install it but it works.


P.S. Thank you.


The ls cmd states ls and prints out the contents of ls in that directory. Thank you for the link.


Hi Mala,
Thanks for your update. I am happy it is working now for you. Good luck with your work.

thanks and regards,