Reading Image with Win32 Disk Imager - Why Does Boot Get Copied with Read Only Allocated Partitions


I was needing a utility to read/clone an SD card without copying all of the additional wasted space on an SD card like the original Win32 Disk Imager Does. From what I can tell, the latest Etcher for Windows only writes to SD card.

So I just tried the latest Win32 Disk Imager which now has a checkbox, “Read Only Allocated Partitions.” With the beaglebone/beagleboard images, I thought (in order to clone an SD card image without wasted space) for sure that with the structure of the BeagleBone/BeagleBoard images having a single ext4 partition and then MLO/u-boot in the “holes” below the partition somewhere, I would have to:

  1. upload/read just the ext4 partition, clicking the Read Only Allocated Partition checkbox with Win32 Disk Imager
  2. Write that uploaded partition to the target SD card.
  3. Re-‘dd’ MLO and u-boot to the target SD card.

But low and behold, I tried booting my board after step #2, and it boots with my modified MLO…

Either Win32 Disk imager, when you click that checkbox, is reading from the start of the SD card to the end of the ext4 partition (and not reading past that point), or something else is going on.

Why is the MLO/u-boot which reside in the “holes” copied as well?

Granted, I didn’t google this in advance, so if this has already been discussed somewhere, then please don’t answer…



From their readme:

"Read Only Allocated Partitions - Option to read only to the end of
the defined partition(s). Ex: Write a 2G image to a 32G device,
reading it to a new file will only read to the end of
the defined partition (2G)."

My guess, it starts from zero -> end of partition... Not the start of
the partition..


Thanks Robert!.

I wasn’t sure what that README statement meant either.

Maybe there’s somewhere where a bug report can be issued against their documentation to clarify…

Regards and see y’all in P.O.